Closed Bug 787521 Opened 12 years ago Closed 4 years ago

Disable theme-related CSS media queries features when not in chrome context

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
87 Branch
Tracking Status
firefox87 --- fixed

People

(Reporter: l702097, Assigned: emilio)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, privacy, site-compat)

Attachments

(1 file)

The following features expose system configuration information and are more harmful than useful in web pages. See #787296

-moz-mac-graphite-theme
-moz-mac-lion-theme
-moz-maemo-classic
-moz-windows-classic
-moz-windows-compositor
-moz-windows-default-theme
-moz-windows-theme

-moz-scrollbar-end-backward
-moz-scrollbar-end-forward
-moz-scrollbar-start-backward
-moz-scrollbar-start-forward
-moz-scrollbar-thumb-proportional
-moz-menubar-drag
Blocks: 787296
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: privacy
Tor browser has a patch for this (at https://gitweb.torproject.org/torbrowser.git/blob/maint-2.2:/src/current-patches/firefox/0010-Limit-device-and-system-specific-CSS-Media-Queries.patch ) - might be a bit too agressive for general usage, but IMHO it wouldn't be hard to extract blocking of Mozilla-specific features outside of Chrome from it...

we can close this: all the above mentioned items are deprecated: they return undefined .. pinging Boris :)

Flags: needinfo?(bzbarsky)

They're not deprecated, but looks like Emilio fixed them being exposed to content a while ago. Some of them have tests for that (the expression_should_not_be_parseable bits in vlayout/style/test/test_media_queries.html) and some don't; it may be worth adding tests for the ones that don't.

Flags: needinfo?(bzbarsky) → needinfo?(emilio)
Assignee: nobody → emilio
Attachment #9199096 - Attachment description: Bug 787521 - Add some extra tests to test_chrome_only_media_queries. → Bug 787521 - Improve tests for chrome-only media queries. r=dholbert,#style
Status: NEW → ASSIGNED

Yeah, improved a bit the tests.

Flags: needinfo?(emilio)
Attachment #9199096 - Attachment description: Bug 787521 - Improve tests for chrome-only media queries. r=dholbert,#style → Bug 787521 - Improve tests for chrome-only media queries. r=dholbert
Attachment #9199096 - Attachment description: Bug 787521 - Improve tests for chrome-only media queries. r=dholbert → Bug 787521 - Improve tests for chrome-only media queries. r=dholbert,#style
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d76812f874e1
Improve tests for chrome-only media queries. r=dholbert
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

This has been added to the release notes for 87, and mentions on MDN removed.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: