Closed Bug 787564 Opened 10 years ago Closed 10 years ago

Today repository cause a black display on SGS2/Otoro due to regression from bug 778079

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: hub, Assigned: fabrice)

References

Details

(Keywords: smoketest)

Attachments

(2 files)

Today repository cause a black display on a Samsung Galaxy S2

dmesg show 

<6>[ 1.755654] failed to copy MFC F/W during init

Which according to someone on #b2g could be the cause of the problem.

It has been reported to not occur on other hardware.
adb logcat: http://pastebin.mozilla.org/1794457

dmesg: http://pastebin.mozilla.org/1794471

testing with a build of 2012-08-29 it works fine

also works fine when flashing only kernel file of 2012-08-31

when flashing the system.img of 2012-08-31 then I get black screen with the above logs
Using a build from 29/08 works fine. So it doesn't block 755568 anymore.
No longer blocks: 755568
FWIW, this happens to me with otoro.
I'm currently bisecting. So far, I know ef2c0cf39715 is good and b449366e9663 is broken. I'm further bisecting.
And the winner is bug 778079
Blocks: 778079
Severity: normal → blocker
blocking-basecamp: --- → ?
Keywords: smoketest
OS: Linux → Gonk
Hardware: x86_64 → ARM
Summary: Today repository cause a black display on SGS2 → Today repository cause a black display on SGS2/Otoro
I can confirm m-i + a backout of bug 778079 works on otoro.
Severity: blocker → normal
blocking-basecamp: ? → ---
OS: Gonk → Linux
Hardware: ARM → x86_64
Severity: normal → blocker
blocking-basecamp: --- → ?
OS: Linux → Gonk
Hardware: x86_64 → ARM
Summary: Today repository cause a black display on SGS2/Otoro → Today repository cause a black display on SGS2/Otoro due to regression from bug 778079
Weird, I tested on mine and this was working. I'll take a look later today.
Just reflashed my L5, and it starts whithout issues (using current inbound + gaia tip). I will try on the otoro next.
How do you flash?
On the L5 we do just ./flash.sh system, and then make install-gaia
build at https://releases.mozilla.com/b2g/latest/otoro_2012-09-03_ics.zip on an otoro works here. Can someone else verify that?
I'm using ./flash.sh ; i guess this could be the problem. install-gaia may be installing things in a different place than what is already in userdata.img, which would mean that b2g isn't reading the data from userdata.img properly. (and considering a build with bug 778079 backed out does work, the data *is* in userdata.img)
install-gaia has not been updated yet to push stuff to /system/b2g/webapps. It looks like it's some file permission issue that make us fail on the otoro. Fix coming...
Okay, so the problem is that bug 778079 requires /system to be mounted rw. If I adb remount and run m-c with bug 778079, it works. If I then remount /system as read-only and restart b2g, it still works. It looks like the only problem is /system/b2g/webapps not being created in system.img, and/or b2g failing to start when /system/b2g/webapps doesn't exist and it fails to create it.
(In reply to Mike Hommey [:glandium] from comment #13)
> Okay, so the problem is that bug 778079 requires /system to be mounted rw.
> If I adb remount and run m-c with bug 778079, it works. If I then remount
> /system as read-only and restart b2g, it still works. It looks like the only
> problem is /system/b2g/webapps not being created in system.img, and/or b2g
> failing to start when /system/b2g/webapps doesn't exist and it fails to
> create it.

That's correct, and this fails because of call to GetDir in FileUtils,jsm with shouldCreate = true
Attached patch patchSplinter Review
Assignee: nobody → fabrice
Attachment #657947 - Flags: review?(21)
https://hg.mozilla.org/mozilla-central/rev/a86b00fa6bc6
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Still happening here.
Severity: blocker → normal
Status: RESOLVED → REOPENED
blocking-basecamp: ? → ---
OS: Gonk → Linux
Hardware: ARM → x86_64
Resolution: FIXED → ---
blocking-basecamp: --- → ?
OS: Linux → Gonk
Hardware: x86_64 → ARM
Severity: normal → blocker
sorry, the usual "Firefox reset the field" bug :-/
On which device? Is there anything in logcat?
still on SGS2 - the only device I have. (hint, I'm the OR on the this bug)
Logcat is very very verbose. What shall I be looking for?
just filter the Gecko and GeckoConsole lines.
E/GeckoConsole( 5138): [JavaScript Warning: "Error in parsing value for 'background-size'.  Declaration dropped." {file: "chrome://browser/content/content.css" line: 188}]
I/GeckoDump( 5138): Opened socket on 9999
I/Gecko   ( 5138): [AccessFu] INFO attach
I/Gecko   ( 5138): Logging GL tracing output to /system/b2g/firefox.trace
I/Gecko   ( 5138): Attempting load of /data/local/egltrace.so
I/Gecko   ( 5138): Attempting load of libEGL.so
E/GeckoConsole( 5138): OpenGL LayerManager Initialized Succesfully.
E/GeckoConsole( 5138): Version: OpenGL ES 2.0
E/GeckoConsole( 5138): Vendor: ARM
E/GeckoConsole( 5138): Renderer: Mali-400 MP
E/GeckoConsole( 5138): FBO Texture Target: TEXTURE_2D
E/GeckoConsole( 5138): GC(T+0.0) Total Time: 67.9ms, Compartments Collected: 83, Total Compartments: 83, MMU (20ms): 0%, MMU (50ms): 0%, SCC Sweep Total: 16.2ms, SCC Sweep Max Pause: 8.6ms, Reason: MAYBEGC, Nonincremental Reason: malloc bytes trigger, Allocated: 6MB, +Chunks: 9, -Chunks: 0
E/GeckoConsole( 5138):     Totals: Mark: 29.1ms, Mark Roots: 3.8ms, Mark Weak: 0.1ms, Mark Gray: 2.2ms, Mark Gray and Weak: 0.1ms, Finalize Start Callback: 0.2ms, Sweep: 24.1ms, Sweep Atoms: 2.0ms, Sweep Compartments: 7.2ms, Sweep Tables: 4.5ms, Sweep Object: 7.7ms, Sweep String: 0.3ms, Sweep Script: 0.4ms, Sweep Shape: 4.4ms, Sweep Discard Code: 0.9ms, Discard Analysis: 1.2ms, Free TI Arena: 0.2ms, Sweep Types: 0.4ms, Clear Script Analysis: 0.3ms, Finalize End Callback: 2.1ms, End Callback: 2.3ms
E/GeckoConsole( 5138): [JavaScript Error: "Error: Don't know about this message type: undefined" {file: "jar:file:///system/b2g/omni.ja!/components/RadioInterfaceLayer.js" line: 463}]
E/GeckoConsole( 5138): [JavaScript Warning: "Error in parsing value for '-moz-transform'.  Declaration dropped." {file: "app://system.gaiamobile.org/style/list_menu/list_menu.css" line: 42}]
E/GeckoConsole( 5138): [JavaScript Warning: "Error in parsing value for '-moz-transform'.  Declaration dropped." {file: "app://system.gaiamobile.org/style/list_menu/list_menu.css" line: 46}]
E/GeckoConsole( 5138): [JavaScript Warning: "Error in parsing value for 'line-height'.  Declaration dropped." {file: "app://system.gaiamobile.org/style/themes/default/menus.css" line: 40}]
I/Gecko   ( 5138): ###################################### forms.js loaded
I/GeckoDump( 5138): XXX FIXME : Got a mozContentEvent: system-app-ready
I/Gecko   ( 5138): *** AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/m2.5/updates.xml
E/GeckoConsole( 5138): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/m2.5/updates.xml
I/Gecko   ( 5138): *** AUS:SVC gCanCheckForUpdates - able to check for updates
E/GeckoConsole( 5138): AUS:SVC gCanCheckForUpdates - able to check for updates
I/Gecko   ( 5138): *** AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/m2.5/updates.xml
E/GeckoConsole( 5138): AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/m2.5/updates.xml
I/Gecko   ( 5138): *** UTM:SVC TimerManager:notify - notified @mozilla.org/updates/update-service;1
E/GeckoConsole( 5138): UTM:SVC TimerManager:notify - notified @mozilla.org/updates/update-service;1
E/GeckoConsole( 5138): GC(T+1.2) Total Time: 82.4ms, Compartments Collected: 96, Total Compartments: 104, MMU (20ms): 0%, MMU (50ms): 34%, SCC Sweep Total: 9.8ms, SCC Sweep Max Pause: 0.7ms, Max Pause: 32.6ms, Allocated: 6MB, +Chunks: 1, -Chunks: 0
E/GeckoConsole( 5138):     Slice: 0, Pause: 32.6 (When: 0.0ms, Reason: SET_NEW_DOCUMENT): Mark: 31.2ms, Mark Discard Code: 0.8ms, Mark Roots: 3.1ms
E/GeckoConsole( 5138):     Slice: 3, Pause: 3.1 (When: 1060.4ms, Reason: TRANSPLANT): Mark: 0.1ms, Mark Delayed: 0.1ms, Sweep: 0.2ms, Sweep Atoms: 2.3ms, Deallocate: 0.1ms, End Callback: 0.2ms
E/GeckoConsole( 5138):     Totals: Mark: 58.1ms, Mark Discard Code: 0.8ms, Mark Roots: 3.1ms, Mark Delayed: 2.4ms, Mark Weak: 0.2ms, Mark Gray: 0.7ms, Finalize Start Callback: 0.3ms, Sweep: 18.6ms, Sweep Atoms: 2.3ms, Sweep Compartments: 7.8ms, Sweep Tables: 4.2ms, Sweep Object: 0.9ms, Sweep String: 0.1ms, Sweep Script: 0.3ms, Sweep Shape: 3.1ms, Sweep Discard Code: 1.0ms, Discard Analysis: 1.9ms, Discard TI: 0.3ms, Free TI Arena: 0.1ms, Sweep Types: 0.5ms, Clear Script Analysis: 0.6ms, Finalize End Callback: 4.0ms, Dea
I/Gecko   ( 5138): *** AUS:SVC Checker:onError - request.status: 2152398878
E/GeckoConsole( 5138): AUS:SVC Checker:onError - request.status: 2152398878
I/Gecko   ( 5138): *** AUS:SVC getStatusTextFromCode - transfer error: Update server not found (check your internet connection), code: 2152398878
E/GeckoConsole( 5138): AUS:SVC getStatusTextFromCode - transfer error: Update server not found (check your internet connection), code: 2152398878
I/Gecko   ( 5138): *** AUS:SVC UpdateService:notify:listener - error during background update: Update server not found (check your internet connection)
E/GeckoConsole( 5138): AUS:SVC UpdateService:notify:listener - error during background update: Update server not found (check your internet connection)
I/Gecko   ( 5138): RIL Worker: DateTimeZone string 12/09/04,19:32:49-28,01,
I/Gecko   ( 5138): RIL Worker: DateTimeZone string 12/09/04,19:32:49-28,01,
then the process restart...
Restarting is a crash, so it's a different issue. This bug was about not loading the system app, while in your log we see it's loaded (and there are some css errors).
The bug was about I get a black screen since that day. The problem is still there from 2012-08-31 14:32 PDT when I filed the bug.
bug 788263 has be filed for the SGS2 specific issue.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
The issue has always been a SGS2 issue.
A black screen would be a blocker.
blocking-basecamp: ? → +
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.