Significant increase in Peak Memory Use Firefox 15 with add ons

NEW
Unassigned

Status

()

Firefox
Extension Compatibility
5 years ago
2 years ago

People

(Reporter: Nigel, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Memshrink:P3])

Attachments

(6 attachments)

(Reporter)

Description

5 years ago
Created attachment 657573 [details]
addons.txt

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

Looked at a few web pages - have noticed that memory use with Addons has dramatically increased with Firefox 15 compared to Firefox 14



Expected results:

Memory use is advertised that its reduced with Firefox 15 - does not appear to be the case.  Peak memory is definately higher
(Reporter)

Updated

5 years ago
Severity: normal → major

Comment 1

5 years ago
You have attached a list of your plugins, but no extensions.

Please click the "Copy all to clipboard" button in about:support and paste into a comment here (or attached as another text file)
Severity: major → normal

Comment 2

5 years ago
In addition type about:memory?verbose in the location bar when you're observing a huge memory use and copy all the memory log (ctrl+a/ctrl+c) then attach the log here (as .txt e.g.).
Whiteboard: [Memshrink]
(Reporter)

Comment 3

5 years ago
Created attachment 657595 [details]
Plugins
(Reporter)

Comment 4

5 years ago
sorry forgot to add this

Comment 5

5 years ago
We want the list of add-ons (like Adblock Plus, Noscript, Videodownload Helper etc), not the list of plugins (like Flash, Java, Quicktime etc). :)

Type about:support and copy the list/array of add-ons.
(Reporter)

Comment 6

5 years ago
That was in the first attachment loaded

Comment 7

5 years ago
Your 1st attachment shows only your plugins.
(Reporter)

Comment 8

5 years ago
Application: Firefox 15.0 (20120824154833)
Operating System: WINNT (x86-msvc)

- Adblock Plus 2.1.2
- Advertising Cookie Opt-out 1.5
- Ant Video Downloader 2.4.7.1
- avast! WebRep 7.0.1466 (Disabled)
- Beef Taco (Targeted Advertising Cookie Opt-Out) 1.3.7
- BetterPrivacy 1.68
- Bookmark Favicon Changer 1.65
- British English Dictionary 1.19.1
- Clear Cache Button 0.9f
- Collusion 0.16.3
- Configuration Mania 1.16.2012081001
- DoNotTrackPlus 2.2.1.611
- Download Statusbar 0.9.10
- Extension List Dumper 1.15.2
- Google Analytics Opt-out Browser Add-on 0.9.6
- GoogleSharing 0.22 (Disabled)
- Master Password Timeout 0.3.1
- Menu Editor 1.2.7
- NewTabURL 2.2.3
- Print Edit 8.6
- ReloadEvery 13.0.0
- Saved Password Editor 2.6.3
- Undo Closed Tabs Button 3.7.1
- Wallflower 1.4
- WebDAV Launcher 1.0.6
- Windows Media Player Extension for Firefox 1.1 (Disabled)
Bug 778318 was similar -- GreaseMonkey was doing something odd and bug 695480 caused its memory consumption to skyrocket.  It's possible that one of the listed add-ons has a similar problem.  Are  you able to narrow it down to a particular add-on by selectively disabling them?  That would help enormously.
Blocks: 695480
Whiteboard: [Memshrink] → [Memshrink:P3]
Also, it would be interesting to know if you are getting any messages in the error console that say "TypeError: can't access dead object".
(Reporter)

Comment 11

5 years ago
(In reply to Nicholas Nethercote [:njn] from comment #10)
> Also, it would be interesting to know if you are getting any messages in the
> error console that say "TypeError: can't access dead object".

The main error is

Timestamp: 05/09/2012 07:29:32
Error: TypeError: gBrowser.getBrowserForDocument is not a function
Source File: chrome://antbar/content/grabber/queryobserver.js
Line: 68
> The main error is
> 
> Timestamp: 05/09/2012 07:29:32
> Error: TypeError: gBrowser.getBrowserForDocument is not a function
> Source File: chrome://antbar/content/grabber/queryobserver.js
> Line: 68

What do you mean by "main"?  Is it occurring most frequently?

Are you getting *any* "can't access dead object" messages?  If not, that would be surprising, because it would (in theory) rule out bug 695480, which is the most likely cause.
(Reporter)

Comment 13

5 years ago
Looking at the Error Console - last time I looked that was the only error seen.

However just restarted, logged into email (webmail) and this page and saw the following

Timestamp: 05/09/2012 07:42:12
Error: An exception occurred.
Traceback (most recent call last):
  File "resource://jid1-f9uj2thwoam5gq-at-jetpack/api-utils/lib/tabs/tab.js", line 71, in _onReady
    this._emit(EVENTS.ready.name, this._public);
  File "resource://jid1-f9uj2thwoam5gq-at-jetpack/api-utils/lib/events.js", line 119, in _emit
    return this._emitOnObject.apply(this, args);
  File "resource://jid1-f9uj2thwoam5gq-at-jetpack/api-utils/lib/events.js", line 149, in _emitOnObject
    listener.apply(targetObj, params);
  File "resource://jid1-f9uj2thwoam5gq-at-jetpack/api-utils/lib/windows/tabs.js", line 102, in _emitEvent
    tabs._emit(type, tab);
  File "resource://jid1-f9uj2thwoam5gq-at-jetpack/api-utils/lib/events.js", line 119, in _emit
    return this._emitOnObject.apply(this, args);
  File "resource://jid1-f9uj2thwoam5gq-at-jetpack/api-utils/lib/events.js", line 149, in _emitOnObject
    listener.apply(targetObj, params);
  File "resource://jid1-f9uj2thwoam5gq-at-jetpack/collusion/lib/main.js", line 374, in null
    var domain = getDomain(ioService.newURI(tab.url, null, null).host);
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.host]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://jid1-f9uj2thwoam5gq-at-jetpack/api-utils/lib/cuddlefish.js -> resource://jid1-f9uj2thwoam5gq-at-jetpack/collusion/lib/main.js :: <TOP_LEVEL> :: line 374"  data: no]
(Reporter)

Comment 14

5 years ago
However looking at peak and operating memory - without logging into web mail, and doing a Firefox restart within the extensions page, noticed that the addon thats causing the significant jump both in peak working memory and memory private working is Add Block Plus - In the order of 100+MB with three subscriptions...
(Reporter)

Comment 15

5 years ago
Confirmed by restarting that AddBlock Plus is the culprit - over 100MB just for it - whereas in Firefox 14 the hit was not as significant.  Peak with 440MB without 302MB.  Startup Peak with 320MB without 220MB
(Reporter)

Comment 16

5 years ago
Noticed that Ablock Lite also has the same issues
Did you ever provide the output of about:memory?verbose that you were asked for? I don't see it anywhere.
Under what circumstances are you seeing this? In Firefox 14, I'm seeing about 50MB overhead from ABP, whereas in 15 I'm seeing 60MB. Neither number is what I'd call ideal, but the difference does not look especially significant.
(Reporter)

Comment 19

5 years ago
Attached file

Note that I am currently running after logging into Bugzila, my email and about memory page - with the following 

PEAK 450 MB (used to be around 330MB) Memory Private 291 MB.  Using Task Manager
(Reporter)

Comment 20

5 years ago
Created attachment 658814 [details]
Memory state after start up only about memory opened
(Reporter)

Comment 21

5 years ago
Created attachment 658815 [details]
Memory state - email, bugzilla and memory page
Nigel, I'm lost as to the problem here. Without any web pages open, you've only got about 140MB of explicit allocations. It's a bit higher with web pages open. I don't see anything unexpected here. Is this memory footprint growing over time? Is it significantly better without add-ons?
(Reporter)

Comment 23

5 years ago
Hi Chris - the issue is that the memory settles - but the start up memory ramps up dramatically to over 190MB and then drops.

This morning my peak working memory is 446,564k while memory private is 314,700K.

Looking yesterday peak was near 1GB while private was 600,000k - thats with the same addons, and having cleared all tabs except the google home page, and having done a memory refresh.  I regret that I did not do a verbose memory dump then!

Issue still exists with Firefox 16.0.2

Comment 24

5 years ago
Private Working set is misleading in the sense it only accounts for process allocated memory, while the Peak Working Set(Memory) actually refers to the maximum reported value in the Working Set(Memory) column at any given time, which is amusingly not enabled by task managers default settings.

Working Set(Memory) refers to the process+shared memory's iirc, and is always larger than Memory(Private Working Set)

TL;DR
Peak Working Set refers to the highest recorded value of memory used by the Process and Shared Memory at any given time.
(In reply to Nigel from comment #23)
> Hi Chris - the issue is that the memory settles - but the start up memory
> ramps up dramatically to over 190MB and then drops.

I wouldn't think that's a problem.

Do you still see this issue when using a current version of firefox?
If you do, please supply output of about:memory and URL.
Flags: needinfo?(firefox)
Whiteboard: [Memshrink:P3] → [closeme 2014-02-15][Memshrink:P3]
(Reporter)

Comment 26

4 years ago
Created attachment 8368420 [details]
About Memory
Flags: needinfo?(firefox)
(Reporter)

Comment 27

4 years ago
The report was after startup and opening two pages.  Typically browsing is to bbc.co.uk and also https://www.google.co.uk/finance?client=ob&q=LON:BP

Updated

4 years ago
Whiteboard: [closeme 2014-02-15][Memshrink:P3] → [Memshrink:P3]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 28

3 years ago
This still exists with Firefox 29.0.1 

Can't see why this has been put as resolved - reopening it
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 29

3 years ago
Can you share current about:memory report?

Comment 30

3 years ago
I would share but it has loads of private information inside, unfortunately. I don't know how to filter it so that the private information does not show.
Any clues?
(In reply to brunoais from comment #30)
> I would share but it has loads of private information inside, unfortunately.
> I don't know how to filter it so that the private information does not show.
> Any clues?

When you do "Add an attachment" you can chose to make the comment and attachment private to the core-security group.
Flags: needinfo?(brunoaiss)
You could also just remove all the URLs from it.

Comment 33

3 years ago
Wayne: I can't find such option.

kayle: My private information is beyond just URLs.
Flags: needinfo?(vseerror)
Flags: needinfo?(khuey)
Flags: needinfo?(brunoaiss)
Created attachment 8433248 [details]
add an attacment private.png

(In reply to brunoais from comment #33)
> Wayne: I can't find such option.

see this screen shot
Flags: needinfo?(vseerror)

Comment 35

3 years ago
There's no such option available to me.
(In reply to brunoais from comment #35)
> There's no such option available to me.

Since everything else is failing, if you send the report directly to me at my @mozilla.com email address I can promise that I will not present anything private from the report and will delete it from my system after I have investigated it.
Flags: needinfo?(khuey)

Comment 37

3 years ago
As long as it does not reach the general public with the confidential data, it's fine. In this case, it's not for your eyes only, you may pass to a Mozillean technician if you need help analysing it. (more info in the e-mail)
E-mail sent.
Hi Nigel,

Are you still having issues with memory peaks in newer versions of Firefox? We're looking to make some final actions on this bug if necessary. Thanks!
Flags: needinfo?(firefox)
Hi Kyle, 

We're looking to triage this bug. Any suggestions/recommendations on where this should go?
Flags: needinfo?(khuey)
(Reporter)

Comment 40

2 years ago
(In reply to Grover Wimberly IV from comment #38)
> Hi Nigel,
> 
> Are you still having issues with memory peaks in newer versions of Firefox?
> We're looking to make some final actions on this bug if necessary. Thanks!

Hi Grover

I just looked at Windows 10 Task Manager Details tab and added the Peak memory column to view.
Firefox 43.0.4 is running with 301 MB however to open with its addons - reduced from the last list, the peak was 459MB.  From testing the worst addon was ad block plus.

I restarted with all adons - extentions disabled - and the base numbers were 179MB with two tabs open and peak of 285MB.

The extension that seemed the worst was ad block plus, however I also normally have enabled as well, Ant Video downloader, Beef Taco, BetterPrivacy, BookMark FavoriteIcon Changer, Clear Cache Button, Configuration Mania, Master Password Timeout Updated, newtaburl, Print Edit, Saved Password Editor, Undo Closed Tabs Button 



I still feel there is an issue.
Flags: needinfo?(firefox)
Cleaning up the Untriaged list and triaging as Extension Compatibility. Developers, if you feel this isn't the right triage, please triage as you see fit. Thanks.
Component: Untriaged → Extension Compatibility
I'm not really working on memory stuff right now, maybe njn has some ideas on what to do here.
Flags: needinfo?(khuey) → needinfo?(n.nethercote)
Users with lots of add-ons often have higher memory usage due to one or more of those add-ons. There's generally not much we can do about that, unfortunately. In this case the extra memory usage doesn't seem all that high to me.

I'm happy to leave the bug open but I would consider it a low priority because it's a moderate problem in a unique configuration.
Flags: needinfo?(n.nethercote)
personally (In reply to Nigel from comment #40)
> (In reply to Grover Wimberly IV from comment #38)
> > Hi Nigel,
> > 
> > Are you still having issues with memory peaks in newer versions of Firefox?
> > We're looking to make some final actions on this bug if necessary. Thanks!
> 
> Hi Grover
> 
> I just looked at Windows 10 Task Manager Details tab and added the Peak
> memory column to view.
> Firefox 43.0.4 is running with 301 MB however to open with its addons -
> reduced from the last list, the peak was 459MB.  From testing the worst
> addon was ad block plus.
> 
> I restarted with all adons - extentions disabled - and the base numbers were
> 179MB with two tabs open and peak of 285MB.
> 
> The extension that seemed the worst was ad block plus, however I also
> normally have enabled as well, Ant Video downloader, Beef Taco,
> BetterPrivacy, BookMark FavoriteIcon Changer, Clear Cache Button,
> Configuration Mania, Master Password Timeout Updated, newtaburl, Print Edit,
> Saved Password Editor, Undo Closed Tabs Button 
> 
> I still feel there is an issue.

This amount of usage sounds quite normal, and the increases you are seeing are entirely caused by addon. I don't think there is anything here in Firefox worth persuing

Comment 45

2 years ago
(In reply to Nicholas Nethercote [:njn] from comment #43)
> Users with lots of add-ons often have higher memory usage due to one or more
> of those add-ons. There's generally not much we can do about that,
> unfortunately. In this case the extra memory usage doesn't seem all that
> high to me.
> 
> I'm happy to leave the bug open but I would consider it a low priority
> because it's a moderate problem in a unique configuration.

A great deal better then it was back then.
(Reporter)

Comment 46

2 years ago
(In reply to Danial Horton from comment #45)
> (In reply to Nicholas Nethercote [:njn] from comment #43)
> > Users with lots of add-ons often have higher memory usage due to one or more
> > of those add-ons. There's generally not much we can do about that,
> > unfortunately. In this case the extra memory usage doesn't seem all that
> > high to me.
> > 
> > I'm happy to leave the bug open but I would consider it a low priority
> > because it's a moderate problem in a unique configuration.
> 
> A great deal better then it was back then.

The situation is better, however its still not brilliant.  Both Firefox itself and extensions require up to 50% more memory when starting than in the settled state
Although this issue cannot be reproduced on my end, due to the amount of comments from developers, I will be changing the bug from Unconfirmed to New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
You need to log in before you can comment on or make changes to this bug.