very slow repaint on scroll (only with border radius on li elements)

RESOLVED DUPLICATE of bug 786817

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 786817
6 years ago
6 years ago

People

(Reporter: kb, Assigned: nrc)

Tracking

({regression})

15 Branch
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox15-, firefox16-, firefox17-, firefox18-)

Details

(URL)

Attachments

(1 attachment)

1.25 MB, application/octet-stream
Details
(Reporter)

Description

6 years ago
Created attachment 657581 [details]
detailed steps

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120824154833

Steps to reproduce:

Scroll the scrollbar (see attached document).
URL http://tomtomexpert.comxa.com/rw/#la=47.99835540203972&ln=7.5823359489440945&z=5&tb=1-3-57-27-7-9-13-2-29-16&tl=41-6-5-4-44-59-58-54-28-56-55-10-12-11-14-47-8-23-24-15-25-32-48-52-30-31-45-46-17


Actual results:

Some elements from the list disappear on scroll start. They reappear about 3 seconds after stopping scrolling. Scrolling is smooth tho.

This bug happens on Firefox 15 and 16. Version 14 and older are working fine.


Expected results:

Scroll without hiding elements.
(Reporter)

Updated

6 years ago
(Reporter)

Updated

6 years ago
Summary: very slow repaint on scroll → very slow repaint on scroll (only with border radius on li elements)
(Reporter)

Comment 1

6 years ago
This bug isn't happening when the border radius is removed from the li elements (tested with firebug on the same page).

removed css property:

.tab_primlist li {
    border-radius: 0.5em 0.5em 0.5em 0.5em;
}

Comment 2

6 years ago
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/2db9df42823d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120504030509
Bad:
http://hg.mozilla.org/mozilla-central/rev/e1a40027dc7e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120504014349
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2db9df42823d&tochange=e1a40027dc7e


Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c608de1b6a53
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120502221102
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/77bf50b33a05
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120502223302
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c608de1b6a53&tochange=77bf50b33a05

Suspected: Bug 716439
Blocks: 716439
Status: UNCONFIRMED → NEW
tracking-firefox15: --- → ?
tracking-firefox16: --- → ?
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
Component: Untriaged → Graphics
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Assignee: nobody → ncameron
(Reporter)

Comment 5

6 years ago
Thanks for the fix, it's working fine! In which version will it be released? 18 or earlier?
(Assignee)

Comment 6

6 years ago
(In reply to kb from comment #5)
> Thanks for the fix, it's working fine! In which version will it be released?
> 18 or earlier?

earlier, exact version TBC :-)

Updated

6 years ago
tracking-firefox15: ? → -
tracking-firefox16: ? → +
tracking-firefox17: ? → +
tracking-firefox18: ? → +
(Assignee)

Comment 7

6 years ago
I confirmed this bug and confirmed it is fixed by the patches in 786817, so closing as a dup.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786817

Updated

6 years ago
tracking-firefox16: + → -
tracking-firefox17: + → -
tracking-firefox18: + → -
You need to log in before you can comment on or make changes to this bug.