If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Trying to save a web page crashes Firefox

RESOLVED WORKSFORME

Status

()

Core
Networking: Cache
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: John David Galt, Unassigned)

Tracking

({crash})

15 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
Twice each on two different web sites (blog pages with lots of comments), I tried to save the page I was viewing by doing File -> Save As from the menu bar.  Result: Firefox crashed.  The crash-reporting helper app came up all four times, so whoever receives those reports should have all four of mine.

Comment 1

5 years ago
Type about:crashes in the location and post some crash IDs (bp-...), please. We need the crash signatures.

Updated

5 years ago
Keywords: stackwanted
(Reporter)

Comment 2

5 years ago
about:crashes shows three IDs caused by this bug:
0b835280-fb63-4cc6-ab71-4fa040900b1d
bp-f8466702-d5f8-442f-9648-d5cd82120901
bp-7ffc3c30-edf3-4a92-aa92-8f4be2120901

Comment 3

5 years ago
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsACString_internal::SetCapacity(unsigned int) ]
Component: General → Networking: Cache
Keywords: stackwanted → crash
Product: Firefox → Core
(Reporter)

Comment 4

5 years ago
No, it doesn't seem to happen in Safe Mode.

Also, the save seems to have completed before the crash.

Comment 5

5 years ago
(In reply to John David Galt from comment #4)
> No, it doesn't seem to happen in Safe Mode.
You need to find out which extension causes that. For a quick method, see https://support.mozilla.org/kb/troubleshoot-extensions-themes-to-fix-problems#w_test-for-faulty-extensions
(Reporter)

Comment 6

5 years ago
After upgrading to 15.0.1 this problem appears to have gone away.  If it comes back I'll look at the add-ons, then maybe reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 7

5 years ago
(In reply to John David Galt from comment #6)
> After upgrading to 15.0.1 this problem appears to have gone away.
It is probably fixed by the only bug that landed in 15.0.1, bug 787743.
Depends on: 787743
This looks to me like an out of memory issue.  I would be very surprised if bug 787743 has actually changed anything with regard to how much memory we consume.

Comment 9

5 years ago
I'm having this issue with 16.0.1. The problem also occurs in safe mode. It only seems to happen with "save web page, complete", not with html only.

Comment 10

5 years ago
qbsmd, can you provide a crash ID from about:crashes?
You need to log in before you can comment on or make changes to this bug.