History list is not updated when removing the last entry using the context menu

VERIFIED FIXED in Firefox 16

Status

()

Firefox for Android
Awesomescreen
VERIFIED FIXED
6 years ago
2 years ago

People

(Reporter: AdrianT, Assigned: lucasr)

Tracking

({regression})

Trunk
Firefox 18
ARM
Android
regression
Points:
---
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(firefox15 unaffected, firefox16 verified, firefox17 verified, firefox18 verified, fennec17+)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 657792 [details]
logs

Nightly 18.0a1 2012-09-02/ Aurora 17.0a2 2012-09-02/ Firefox Mobile 16.0b1 
Samsung Galaxy Tab 2 7.0 (Android 4.0.4)/ Samsung Galaxy R (Android 2.3.4)

Steps to reproduce:
1. Make sure you have entrees in the History section.
2. Tap the URL bar to access the History tab.
3. Long tap on one entree for the context menu to appear.
4. Repeat step 4 and remove all entrees using the remove button.

Expected:
A toast notification appears whit the message "Page Removed" and all entrees from the History section are removed. 

Actual:
If there is only one item in the history section the toast notification appears but the item is still present. Only after going back and accessing another time the awesome-menu the History tab is updated and the entree is removed.

Note:
The issue was resolved in bug 759120 and is not reproducible on Firefox Mobile 15 release. This is a regression.
Let's find a window.
Keywords: regressionwindow-wanted

Updated

6 years ago
Flags: in-moztrap?(adrian.tamas)
(Reporter)

Comment 2

6 years ago
A new test case has been created in the BFTs run in the History suite:

https://moztrap.mozilla.org/manage/cases/_detail/6331/
Flags: in-moztrap?(adrian.tamas) → in-moztrap+
(Reporter)

Comment 3

6 years ago
Good build: 2012-06-30
Bad build: 2012-07-01

Push log: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f08d285b63b0&tochange=d9d61d199b11
Looks like bug 759041.
Blocks: 759041
(Reporter)

Updated

6 years ago
Keywords: regressionwindow-wanted
tracking-fennec: ? → 17+
Assignee: nobody → wjohnston
(Assignee)

Comment 5

6 years ago
Created attachment 659182 [details] [diff] [review]
Re-apply patch from bug 759120 on new awesomebar tab code
Attachment #659182 - Flags: review?(wjohnston)
(Assignee)

Updated

6 years ago
Assignee: wjohnston → lucasr.at.mozilla
Attachment #659182 - Flags: review?(wjohnston) → review+
(Assignee)

Comment 7

6 years ago
Comment on attachment 659182 [details] [diff] [review]
Re-apply patch from bug 759120 on new awesomebar tab code

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 759041 refactoring a large part of the awesomescreen code and somehow reverted a patch in the process.
User impact if declined: History list in awesomescreen is not updated when user removes the last item.
Testing completed (on m-c, etc.): Existing patch (from bug 759120) re-applied in new code. We now it works.
Risk to taking this patch (and alternatives if risky): Low, known issue with proven patch.
String or UUID changes made by this patch: None.
Attachment #659182 - Flags: approval-mozilla-beta?
Attachment #659182 - Flags: approval-mozilla-aurora?

Comment 8

6 years ago
Once this has had a little time to bake on Nightly, we'll approve for Aurora/Beta.
https://hg.mozilla.org/mozilla-central/rev/b94134ca469a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18

Updated

6 years ago
status-firefox18: affected → ---
The last entry is removed as expected from History Tab. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-13)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
status-firefox18: --- → verified
Attachment #659182 - Flags: approval-mozilla-beta?
Attachment #659182 - Flags: approval-mozilla-beta+
Attachment #659182 - Flags: approval-mozilla-aurora?
Attachment #659182 - Flags: approval-mozilla-aurora+

Updated

6 years ago
status-firefox16: affected → fixed
status-firefox17: affected → fixed
This issue is not reproducible anymore on the latest Aurora and Nightly build.

--
Device: Galaxy Note
OS: Android 4.0.4
status-firefox16: fixed → verified
status-firefox17: fixed → verified
You need to log in before you can comment on or make changes to this bug.