The default bug view has changed. See this FAQ.

Replace nsIMsgIncomingServer.useSSL with nsMsgSocketType.SSL (missing from patch for Bug 525238)

RESOLVED FIXED in seamonkey2.15

Status

SeaMonkey
MailNews: General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

({regression})

Trunk
seamonkey2.15
regression

SeaMonkey Tracking Flags

(seamonkey2.12 fixed, seamonkey2.13 fixed, seamonkey2.14 fixed, seamonkey2.15 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Bug 525238 removed Components.interfaces.nsIMsgIncomingServer.useSSL and replaced it with Components.interfaces.nsMsgSocketType.SSL but BenB forgot to change SeaMonkey's version of CopyMessageUrl()
(Assignee)

Comment 1

5 years ago
Created attachment 657877 [details] [diff] [review]
Patch v1.0 fixit.

[Approval Request Comment]
Regression caused by (bug #): Bug 525238 - Authentication method (plaintext/encrypted password, Kerberos/GSSAPI etc.) should be explicit, not just "Secure authentication"
User impact if declined: Unable to copy message location if server protocol is snews.
Testing completed (on m-c, etc.): baked in Thunderbird since 2010-03-19
Risk to taking this patch (and alternatives if risky): minimal
String changes made by this patch: none.
Attachment #657877 - Flags: superreview?(neil)
Attachment #657877 - Flags: review?(neil)
Attachment #657877 - Flags: approval-comm-release?
Attachment #657877 - Flags: approval-comm-beta?
Attachment #657877 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #657877 - Flags: superreview?(neil)
Attachment #657877 - Flags: review?(neil)
Attachment #657877 - Flags: review+
(Assignee)

Comment 2

5 years ago
Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/163203274af7

Updated

5 years ago
Attachment #657877 - Flags: approval-comm-release?
Attachment #657877 - Flags: approval-comm-release+
Attachment #657877 - Flags: approval-comm-beta?
Attachment #657877 - Flags: approval-comm-beta+
Attachment #657877 - Flags: approval-comm-aurora?
Attachment #657877 - Flags: approval-comm-aurora+
(Assignee)

Comment 3

5 years ago
Pushed:
http://hg.mozilla.org/releases/comm-aurora/rev/0d0f0f287b6d
http://hg.mozilla.org/releases/comm-beta/rev/7301525379a2
http://hg.mozilla.org/releases/comm-release/rev/7621b825fdaa
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.12: --- → fixed
status-seamonkey2.13: --- → fixed
status-seamonkey2.14: --- → fixed
status-seamonkey2.15: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.15

Comment 4

5 years ago
> but BenB forgot to change SeaMonkey's version of CopyMessageUrl()

Sorry. Thanks for fixing it.
You need to log in before you can comment on or make changes to this bug.