Last Comment Bug 787980 - Talos should run tests with -new-instance and smarter process management
: Talos should run tests with -new-instance and smarter process management
Status: RESOLVED DUPLICATE of bug 776947
:
Product: Testing
Classification: Components
Component: Talos (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-03 11:09 PDT by Nathan Froyd [:froydnj]
Modified: 2012-09-05 02:08 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Nathan Froyd [:froydnj] 2012-09-03 11:09:08 PDT
It would be *really* nice if running Talos locally didn't require you to shut down your existing Firefox instances.  I realize this doesn't matter so much for the server-side testing we do, but it is a huge deal for running locally on your desktop.
Comment 1 Joel Maher ( :jmaher) 2012-09-03 12:37:16 PDT
I have a patch that works up on bug 776947.  It is actually quite involved.  Maybe we should put some work into making talos a bit cleaner to support it and this problem will be solved once and for all!

*** This bug has been marked as a duplicate of bug 776947 ***
Comment 2 Jeff Hammel 2012-09-03 12:57:52 PDT
As said on bug 776947, I really think we should put effort into getting Talos on mozprocess.  There are several "wonky" things wrt Talos process management currently and I'd rather work on fixing them vs hacking around them.

That said, if you're interested in actually getting numbers out of the results (vs just making sure that Talos runs) then closing other Firefoxen (and other expensive processes) is a must, regardless of whether Talos checks for it or not.

Note You need to log in before you can comment on or make changes to this bug.