Note: There are a few cases of duplicates in user autocompletion which are being worked on.

xhr instanceof XMLHttpRequest == false in workers

RESOLVED FIXED in Firefox 16

Status

()

Core
DOM: Workers
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: baku, Assigned: bz)

Tracking

Trunk
mozilla18
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox16 fixed, firefox17 fixed)

Details

(Whiteboard: [qa-])

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
var xhr = new XMLHttpRequest();
  if(xhr instanceof XMLHttpRequest) ...

should be true.

Updated

5 years ago
Component: DOM → DOM: Workers
(Reporter)

Comment 1

5 years ago
Created attachment 658113 [details] [diff] [review]
mochitest
(Assignee)

Comment 2

5 years ago
Created attachment 658119 [details] [diff] [review]
Fix instanceof for XHR and XHR.upload in workers.
Attachment #658119 - Flags: review?(peterv)
(Assignee)

Updated

5 years ago
Assignee: nobody → bzbarsky
Whiteboard: [need review]
Attachment #658119 - Flags: review?(peterv) → review+
(Assignee)

Comment 3

5 years ago
Peter, do you think this is worth backporting to aurora or beta?
(Assignee)

Comment 4

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/d10e508e4890
Flags: in-testsuite+
Whiteboard: [need review]
Target Milestone: --- → mozilla18
(Assignee)

Comment 5

5 years ago
Comment on attachment 658119 [details] [diff] [review]
Fix instanceof for XHR and XHR.upload in workers.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 740069
User impact if declined: Some scripts in workers will get incorrect instanceof
   values, which may cause some pages using workers to break.
Testing completed (on m-c, etc.): Passes attached tests.
Risk to taking this patch (and alternatives if risky): Risk is low.
String or UUID changes made by this patch: None.
Attachment #658119 - Flags: approval-mozilla-beta?
Attachment #658119 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d10e508e4890
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Attachment #658119 - Flags: approval-mozilla-beta?
Attachment #658119 - Flags: approval-mozilla-beta+
Attachment #658119 - Flags: approval-mozilla-aurora?
Attachment #658119 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/1f774f8fdfe4
https://hg.mozilla.org/releases/mozilla-beta/rev/c069535ea457
tracking-firefox16: --- → ?
tracking-firefox17: --- → ?
(Assignee)

Updated

5 years ago
status-firefox16: --- → fixed
status-firefox17: --- → fixed
tracking-firefox16: ? → ---
tracking-firefox17: ? → ---
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.