Closed Bug 788281 Opened 10 years ago Closed 8 years ago

expose event data including product details releases

Categories

(Input Graveyard :: Dashboard, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: willkg, Assigned: willkg)

References

Details

(Whiteboard: u=dev c=general p=2 s=input.2014q3)

Product details has the dates that various products were released. We can use those dates to produce release lines in the dashboard chart.

There are a few things to get figured out here, though:

1. we'd need a cron job to update the product details nightly

2. we don't want to be parsing JSON at request time (ew), so we'll need to have a command to pull the relevant product details bits into some table structure (maybe that's done already?)

3. we'd need to write the code to add that data to the chart--but it needs to be the relevant data for the chart (i.e. the right product)

4. maybe other things to figure out as well!
Making this a P5. It's neat, but not important now.
Priority: -- → P5
Adding block on 780626 because this is part of the phase 0 rewrite.
Blocks: 780626
Adding block on 790835 because this requires a cron job.
Depends on: 790835
I actually don't think this requires a cron job. We can wing this by adding the required commands to the update_site.py script which will get run on -dev every 5 minutes and on -stage and -prod every time we deploy.
Sounds good. I'll remove the dependency then.
No longer depends on: 790835
This is a nice-to-have, but shouldn't block phase 0.
No longer blocks: 780626
Putting these in my queue for this quarter.
Assignee: nobody → willkg
Whiteboard: u=dev c=infrastructure p= → u=dev c=general p= s=input.2013q2
Product details gets updated explicitly by developers so this won't be automatic which is a complication.

Regardless, it's nice to have, but I'm pushing it off.
Whiteboard: u=dev c=general p= s=input.2013q2 → u=dev c=general p= s=
Unassigning it from me.

Interestingly, Input has bug #1007835 which is very similar.
Assignee: willkg → nobody
Two things:

1. I know a lot more about this stuff than I did when I wrote this bug and this bug is crazypants.

2. Right now the output for update_product_details is checked into the fjord git repository. Currently we need to update this manually, but we don't.


The way we should really do this is:

1. Remove the product details stuff from the git repository.

2. Fix the deploy script to run update product details.

3. Write an "events" app that uses product details and other things and merges all that data into event streams. Helper functions would return a stream of events between two dates for some context. Plus we should create an API endpoint to expose this information to everyone else because that would make everyone happy.


That all sounds super fine, so I think I want to do it in the near future. Sticking it in this quarter.

Changing the summary and rescoping. We can add event lines to the dashboards in another bug.
Summary: use product details history to produce release lines in chart → expose event data including product details releases
Whiteboard: u=dev c=general p= s= → u=dev c=general p= s=input.2014q3
This got slightly more complicated because django-mozilla.product-details changed names, moved to a new central repository and had a bug that I needed to fix.
Assignee: nobody → willkg
Status: NEW → ASSIGNED
Wow--this got messy, but it's done-ish!

https://github.com/mozilla/fjord/commit/9f6f45df841061007eb999fdb53355efd51c92c0
https://github.com/mozilla/fjord/commit/286869e92716015aa2164ae980b00142154c50ff
https://github.com/mozilla/fjord/commit/583138147d56bb5d0299db5e8685b870166c560f
https://github.com/mozilla/fjord/commit/46174dce22a7369c265767b7059083dca3a44d96
https://github.com/mozilla/fjord/commit/171462839a7a1cda94be54b1006de45b68891243
https://github.com/mozilla/fjord/commit/bbedc869f260bc7fe9356cde6f29eb7fbe659828

I'll push this later. Also, we need a follow-up bug for creating events that aren't in product details (releases for non Firefox/Fennec products, etc) and adding that to the API. After I finish those two things, then we can close this out.
Whiteboard: u=dev c=general p= s=input.2014q3 → u=dev c=general p=2 s=input.2014q3
Pushed to production just now.

Created bug #1071609 to implement additional event data and exposing it to the API.

That covers everything. Marking this as FIXED.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1071611
Product: Input → Input Graveyard
You need to log in before you can comment on or make changes to this bug.