Download panel entry limit needs to be configurable

RESOLVED WONTFIX

Status

()

Firefox
Downloads Panel
--
enhancement
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: Stephan Sokolow, Unassigned)

Tracking

17 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20120903063249

Steps to reproduce:

As usual, started four downloads in parallel off GOG.com or MediaFire, then clicked the download panel to check my progress.


Actual results:

It showed three downloads and asked me to open a whole new window just to check progress on the fourth.

I also couldn't find any about:config key to adjust where it made the cut-off. (I'd probably set it to 6 or 7, given the size of my screen)


Expected results:

It should be configurable so nobody has to be stuck reverting to the inferior Chrome-style Download Statusbar extension just because the downloads panel won't show all their in-progress downloads.

Given the kinds of parallelism sites like GOG.com and MediaFire tend to permit and the sizes of screens these days, it'd probably also make more sense to default to four downloads as the limit. (Four downloads also shouldn't have too much trouble fitting on a screen 480px tall and even my little OpenPandora palmtop can do that)

Updated

5 years ago
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Untriaged → Downloads Panel
Ever confirmed: true
we won't make it configurable (more options is often not a solution to problems), though we definitely need to figure out a better way to handle the limits, that will be done in bug 780837.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.