Status

()

Core
ImageLib
P3
normal
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: Marcin Krakowiak, Assigned: Stuart Parmenter)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9+) Gecko/20010503
BuildID:    2001050320

page is renderd ok, but scroling up and down gives black background

Reproducible: Always
Steps to Reproduce:
1. visit http://www.fiber.net.pl
2. scrol down and up

Actual Results:  black bacground

Expected Results:  normal (blue?) background

Comment 1

17 years ago
Confirmed
Platform: PC
OS: Windows 98
Mozilla Build: 2001050104


Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
This seems to be an imagelib issue-- the black only shows up where the
background image shows.  Luckily (?) this site was very slow to load so I got to
test scrolling before and after the background image loaded.

Before image loading -> solid purple background color, no black.
After image loading -> black shows in areas where background image is, not page
background.

Perhaps related to transparency issues we've been seeing recently?  If so this
is a dupe of something recent.

Comment 3

17 years ago
updating component.
Assignee: asa → pavlov
Component: Browser-General → ImageLib
QA Contact: doronr → tpreston

Comment 4

17 years ago
Pav sez: this may be related to the banding/background problems being tracked in
bug 65708
Target Milestone: --- → mozilla0.9.2

Comment 5

17 years ago
Related to bug 83726 (mother of all non-animated transparent GIF turning black
after redraw) but IMHO separate.
(Assignee)

Updated

17 years ago
Priority: -- → P3
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 6

17 years ago
WFM on 2001062306/Linux-i386, but I remember it to be broken about a month ago.
Probably fixed by something that happened on the way.

Comment 7

17 years ago
Doesn't look like this is getting fixed before the freeze tomorrow night.
Pushing out a milestone.  Please correct if I'm mistaken.
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.5 → Future
I was about to report this as a new bug, but I think it's this one -- solely related to table cells with the rowspan attribute, with CSS background colors, using strict rendering not quirks mode.

See testcases: http://www.macedition.com/cb/testers/nn62test1.html (doesn't happen)
http://www.macedition.com/cb/testers/nn62test1.html (does happen)

Observed in Netscape 6.2 and reported by others in Mozilla 0.9.5. Causing unsightliness in www.macedition.com.  

Regards, CB
Sorry, test case where the scrolling problem occurs is 
http://www.macedition.com/cb/testers/nn62test2.html
hm, is anyone still seeing this bug? this works for me with 2002090415, win98
marking worksforme as there was no reply for three months.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.