Having a DataView of a buffer in a different scope crashes on GC

RESOLVED DUPLICATE of bug 787775

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 787775
6 years ago
6 years ago

People

(Reporter: eeejay, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 658706 [details]
test case - run in xpcshell

At least that is what I think is happening... It seems to be a regression from bug #720949.
(Reporter)

Updated

6 years ago
Summary: Having a DataView of an buffer in a different scope crashes on GC → Having a DataView of a buffer in a different scope crashes on GC
(Reporter)

Comment 1

6 years ago
Created attachment 658707 [details]
Stack trace
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787775
You need to log in before you can comment on or make changes to this bug.