Last Comment Bug 788906 - LastPass add-on causing heap-unclassified to grow
: LastPass add-on causing heap-unclassified to grow
Status: RESOLVED WORKSFORME
[MemShrink:P2]
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: x86_64 Linux
: -- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: DarkMatter
  Show dependency treegraph
 
Reported: 2012-09-05 18:32 PDT by Nicholas Nethercote [:njn]
Modified: 2014-05-28 16:30 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Nicholas Nethercote [:njn] 2012-09-05 18:32:00 PDT
(This is from a commenter named "mindugo" on my blog:  http://blog.mozilla.org/nnethercote/2012/09/05/memshrink-progress-week-63-64/comment-page-1/#comment-7439.  I haven't tried to reproduce it.)

I think LastPass extension is still leaking to heap-unclassified and it’s very similar to “Restartless Restart + SmartSearch” leak. I tested like this:

1. Install latest Nightly build.
2. Create new profile.
3. Install “LastPass” (https://addons.mozilla.org/en-US/firefox/addon/lastpass-password-manager).
4. Install “Restartless Restart 8″ (https://addons.mozilla.org/en-US/firefox/addon/restartless-restart).
5. Restart Firefox.
6. Login to LastPass account using extension.
7. Open a new tab with about:memory. Heap-unclassified is ~ 7-8Mb.
8. Open a new tab with http://www.gsmarena.com/apple_ipad_3-review-739.php
9. Click on the first iPad image in the review – a popup opens.
10. Close the popup.
11. Repeat 9-10 steps 20 times.
12. Go to about:memory tab and click “Minimize memory usage” button.
13. Check line with heap-unclassified – it is ~75Mb and never goes down.

This doesn’t happen (heap-unclassified stays at about the same level with just minimal increase) while user IS NOT logged-in to LastPass account, even if LastPass extention is installed and enabled in Firefox.

I reported this to LastPass support team a while ago and they could reproduce the problem eventually.

You can get similar result with LastPass and some other extensions installed, e.g. TabGroups Menu.
Comment 1 Kris Maglione [:kmag] 2012-09-20 11:44:42 PDT
I can confirm this. With LastPass insalled, heap-unclassified seems to grow fairly rapidly and consistently as websites are visited. This does not happen without the add-on installed.
Comment 2 Matt A 2014-04-20 10:26:00 PDT
Is this resolved yet? I was looking into why my Firefox memory seems to be growing and this is one of those addons I really need so it was the only one I haven't disabled when trying to find memory leaks. It seems like this is the culprit for sure of my Firefox going from 400mB to 1400mB over the course of 24 hours.
Comment 3 Kris Maglione [:kmag] 2014-04-21 15:48:01 PDT
This doesn't seem to be an issue anymore.

Note You need to log in before you can comment on or make changes to this bug.