Closed Bug 788918 Opened 7 years ago Closed 7 years ago

text-shadow-selected reftests only valid when focused

Categories

(Core :: Layout: Text and Fonts, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: heycam, Assigned: heycam)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
These tests rely on the fact that text colour will be white when the text is selected, but that is not the case when the window doesn't have focus on Windows and Linux.  (It'll be light grey, the background colour, since the foreground/background will be swapped.)  I'm not really sure if assuming selected text being white is valid, but I guess it's good enough for our regression tests.
Attachment #658723 - Flags: review?(jfkthame)
(The patch just makes these tests grab the focus.)
Assignee: nobody → cam
Status: NEW → ASSIGNED
Comment on attachment 658723 [details] [diff] [review]
patch

Review of attachment 658723 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine, thanks.
Attachment #658723 - Flags: review?(jfkthame) → review+
https://hg.mozilla.org/mozilla-central/rev/4b83eb1d32e3
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.