Secure HTML bugmail is still missing bug summary / subject

RESOLVED FIXED

Status

()

--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: jruderman, Assigned: glob)

Tracking

({regression})

Production
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Even after clicking the message in Thunderbird's message list, the subject is shown as "[Bug ______] (Secure bug ______ updated)".

This is with bugmail sent today, which should have the fix for bug 785219 deployed.
For me it was broken, got fixed, and then broke again sometime between 15:43 and 19:47 PDT today.
(Assignee)

Comment 2

7 years ago
(In reply to Jesse Ruderman from comment #0)
> This is with bugmail sent today, which should have the fix for bug 785219
> deployed.

indeed -- bug 785219 only adds it to text/plain parts.

(In reply to David Baron [:dbaron] from comment #1)
> For me it was broken, got fixed, and then broke again sometime between 15:43
> and 19:47 PDT today.

no changes were made to bmo within that timeframe (the last code change was a week ago).
Then you have an intermittent bug in b.m.o.

I got bugmail from Bug 787089 at
Date: Thu, 06 Sep 2012 02:47:46 +0000
that had no Subject: in the encrypted text/plain part.
(Assignee)

Comment 4

7 years ago
(In reply to David Baron [:dbaron] from comment #3)
> Then you have an intermittent bug in b.m.o.

can i get the X-Generated-By header from that message please, and also from one that included the subject if possible.
Had subject -- pp-app-bugs02.phx.mozilla.com/pp-app-bugs01.phx.mozilla.com(6783)

Missing subject -- pp-app-bugs02.phx.mozilla.com
(Assignee)

Comment 6

7 years ago
thanks reed and dbaron.  i've raised bug 788948 to track that issue.
(Assignee)

Updated

7 years ago
Assignee: nobody → glob
**without** subject:
Received: (from root@localhost)
        by pp-app-bugs01.phx.mozilla.com (8.13.8/8.13.8/Submit) id
        q862lpio028872;
        Wed, 5 Sep 2012 19:47:51 -0700
X-Generated-By: pp-app-bugs03.phx.mozilla.com

with subject:
Received: (from root@localhost)
        by pp-app-bugs02.phx.mozilla.com (8.13.8/8.13.8/Submit) id
        q85MhBoc021774;
        Wed, 5 Sep 2012 15:43:11 -0700
X-Generated-By:
pp-app-bugs03.phx.mozilla.com/pp-app-bugs02.phx.mozilla.com(12841)

with subject:
Received: (from root@localhost)
        by pp-app-bugs02.phx.mozilla.com (8.13.8/8.13.8/Submit) id
        q85MeuUm019670;
        Wed, 5 Sep 2012 15:40:56 -0700
X-Generated-By:
pp-app-bugs03.phx.mozilla.com/pp-app-bugs02.phx.mozilla.com(12864)

with subject:
Received: (from root@localhost)
        by pp-app-bugs01.phx.mozilla.com (8.13.8/8.13.8/Submit) id
        q85MHUnZ029994;
        Wed, 5 Sep 2012 15:17:30 -0700
X-Generated-By: pp-app-bugs03.phx.mozilla.com/pp-app-bugs01.phx.mozilla.com(6760)
(Assignee)

Comment 8

7 years ago
(In reply to David Baron [:dbaron] from comment #7)
> **without** subject:
> Received: (from root@localhost)
>         by pp-app-bugs01.phx.mozilla.com (8.13.8/8.13.8/Submit) id
>         q862lpio028872;
>         Wed, 5 Sep 2012 19:47:51 -0700
> X-Generated-By: pp-app-bugs03.phx.mozilla.com

in bug 788948 fox2mike found a rogue process on pp-app-bugs01, which has been restarted.
(Assignee)

Comment 9

7 years ago
Posted patch patch v1Splinter Review
Attachment #658810 - Flags: review?(dkl)
While you're there, why are you using CRs (\015s) in the text/plain part?  The subject and the blank line after it are the only places in the text/plain part that have CRs.  (And in mutt, they show up as "^M".)
(Assignee)

Comment 11

7 years ago
(In reply to David Baron [:dbaron] from comment #10)
> While you're there, why are you using CRs (\015s) in the text/plain part? 
> The subject and the blank line after it are the only places in the
> text/plain part that have CRs.  (And in mutt, they show up as "^M".)

i'm unable to reproduce this with mutt on linux, both with and without this patch.
mutt-1.5.21-7 gnupg2-2.0.18-2

when i decrypt messages on my mac and examine the line endings, they are consistent.
Comment on attachment 658810 [details] [diff] [review]
patch v1

Review of attachment 658810 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good and works as expected. r=dkl

::: extensions/SecureMail/Extension.pm
@@ +523,5 @@
>  }
>  
> +# Insert the subject into the part's body, as the subject of the message will
> +# be sanitised.
> +# XXX this incorrectly assumes all parts of the message are the body

You could grep for "You are receiving this mail because" which is in both the HTML and text bodies always. But as this is not a regression since we were not doing this before, we can worry about it later.
Attachment #658810 - Flags: review?(dkl) → review+
(Assignee)

Comment 13

7 years ago
(In reply to David Lawrence [:dkl] from comment #12)
> You could grep for "You are receiving this mail because" which is in both
> the HTML and text bodies always.

a safer way would be to only work on parts who's parent is multipart/alternative.  but as you say, that's fodder for later.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.0/
modified extensions/SecureMail/Extension.pm
Committed revision 8322.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/SecureMail/Extension.pm
Committed revision 8344.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.