Closed Bug 789002 Opened 7 years ago Closed 7 years ago

I would like to be able to edit the dictionnary entries

Categories

(Core :: Spelling checker, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 715410

People

(Reporter: philippe.lebourg, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20120615 Firefox/13.0.1 SeaMonkey/2.10.1
Build ID: 20120615050225

Steps to reproduce:

 I entered entries (add to dictionnary) in the past but the software would not enable by then the user to undo this. I would like to be able to remove these unwanted entries from the dictionnary.


Actual results:

No clue about how to do it.


Expected results:

Offer an option to edit the entries of the dictionnary.
Severity: normal → enhancement
(I searched & simply copied this from elsewhere.  It is correct.)

"Inside your profile folder, find the file called persdict.dat and open it up in your text editor of choice."

(Now know what to look for...)

http://kb.mozillazine.org/Persdict.dat
Thanks a lot.
Eventually, it looks like the issue is not in old data entered by mistake but is in the base dictionnary or in the search strategy used by the spellchecker that does not take correctly into account (for proposals of correction) the characters with diacritical marks at the beginning of a word: in french, the word CA doesn't exist (the abbreviation does -as well as in english- but I would not expect shortcuts to be in the dictionnary) but the tool would not propose the same with a cedilla under the C (ÇA) that does exist. In fact, it doesn't even notice there is a possible mistake... The same goes for other words.
Could it be that the "word" is indeed found in the standard dictionnary? If so, how can it be removed?
BR,
PhL
Better yet (I found that the "word" indeed IS in the revised dictionnary from 1990!), could we have an option to disable the search of the spell-checker in the acronyms (and/or other types of lexical fields)?
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715410
I strongly disagree. The enhancement proposal is to have the search engine offering more flexibility on the kind of words it considers, chosen on the basis of some dictionary field (lexical, semantical, grammatical, etc) and/or values(e.g. suppress all acronyms from matching patterns).
It is totally different from proposed solution to bug #715410 that was about "undoing add-an-entry-in-the-dictionnary".
Would you please re-consider the classification and status? (I switch it back to Unconfirmed in the meanwhile).
BR,
PhL
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Your original report match exactly on Bug 715410, if you want to change this bug scope, then write in detail what your proposition is and change bug's summary accordingly. As I see, you want some change in spell checking processing, then this section is not appropriate place, moving
Component: General → Spelling checker
OS: Windows XP → All
Product: SeaMonkey → Core
Hardware: x86 → All
Version: SeaMonkey 2.13 Branch → unspecified
OK OK. I'll manage another entry.
BR.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715410
You need to log in before you can comment on or make changes to this bug.