[ia] Archived articles, templates, etc. are being listed in the new IA.

RESOLVED FIXED in 2012Q3

Status

support.mozilla.org
Knowledge Base Software
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: rrosario, Assigned: rrosario)

Tracking

unspecified
2012Q3

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: u=user c=wiki p=1)

(Assignee)

Description

6 years ago
Verdi reported:
"Templates are being listed when they shouldn't. We force editors to pick a product and topic for everything, templates included, so maybe the problem is there. Anyway, we should only display "how to" and "troubleshooting" articles."

Also, I realized we aren't filtering out archived articles.

In this bug we will change the articles listed to only:
* documents with is_archived=False
* documents in category 10 or 20 (Troubleshooting and How to)

Please Note: that this means articles on how to contribute and administration will not be accessible by browsing the IA.
(Assignee)

Comment 1

6 years ago
I think this is the wrong thing to do. Why do we have topics like "Contributor resources" and "Knowledge Base resources"?

I think we want to only filter OUT documents categorized as templates or navigation. I'll go with that.
(Assignee)

Comment 2

6 years ago
Landed in prod:

https://github.com/mozilla/kitsune/commit/6639ceecfa86d8fb2be865dd31370b2a6e680b50

Now we shouldn't be able to browse to archived, template or navigation articles.
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.