Last Comment Bug 789053 - Feed validator needs an encoded uri
: Feed validator needs an encoded uri
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Thunderbird 18.0
Assigned To: alta88
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 07:33 PDT by alta88
Modified: 2012-10-08 01:29 PDT (History)
3 users (show)
ryanvm: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
patch (1.08 KB, patch)
2012-09-06 07:35 PDT, alta88
mconley: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description alta88 2012-09-06 07:33:52 PDT

    
Comment 1 alta88 2012-09-06 07:35:37 PDT
Created attachment 658877 [details] [diff] [review]
patch
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-09-13 08:23:37 PDT
Comment on attachment 658877 [details] [diff] [review]
patch

Review of attachment 658877 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks!

Bonus points if you follow this up with a test case...
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-09-19 17:17:24 PDT
https://hg.mozilla.org/comm-central/rev/757e3706c5b1
Comment 4 alta88 2012-09-25 17:35:43 PDT
Comment on attachment 658877 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined:  the validation tool won't work with feed urls needing encoding.
Testing completed (on c-c, etc.): locally.
Risk to taking this patch (and alternatives if risky): possibly less than 0..
Comment 5 Justin Wood (:Callek) 2012-10-07 20:21:08 PDT
Comment on attachment 658877 [details] [diff] [review]
patch

Review of attachment 658877 [details] [diff] [review]:
-----------------------------------------------------------------

a+=me [flag notwithstanding]
Comment 6 Justin Wood (:Callek) 2012-10-07 20:51:53 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/cb2115024fa9

Note You need to log in before you can comment on or make changes to this bug.