Closed Bug 789124 Opened 8 years ago Closed 8 years ago

Bug 777591 assumes the jar command to be used is in the search path

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 18
Tracking Status
firefox17 --- unaffected
firefox18 --- fixed

People

(Reporter: wgianopoulos, Assigned: cpeterson)

References

Details

(Keywords: regression)

Attachments

(1 file)

Bug 777591 assumes the jar comand to be used is in the search path.

It should respect the --with-java-bin-path configure option if it was specified.
I would have filed this as a blocker but managed to get my development builds to work by creating a symlink in my ~/bin directory to the correct jar command.
Assignee: nobody → cpeterson
Status: NEW → ASSIGNED
Turns out the symlink did not work.  I actually had to define an alias in my build process.
Kyle, can you please review this Android makefile change?

I replaced `jar` with `$(JAR)` because I can't assume Java's jar tool is in PATH. The default value of $(JAR) works for me and I verified that I can override $(JAR) with mozconfig's --with-java-bin-path option.
Attachment #659530 - Flags: review?(khuey)
OS: Linux → Android
Hardware: x86_64 → ARM
Target Milestone: --- → Firefox 18
https://hg.mozilla.org/mozilla-central/rev/909bb2d2ef8a
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.