All users were logged out of Bugzilla on October 13th, 2018

restrict the global history list to x elements

VERIFIED DUPLICATE of bug 55293

Status

--
enhancement
VERIFIED DUPLICATE of bug 55293
18 years ago
2 months ago

People

(Reporter: vbossica, Assigned: alecf)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Save of only the x last url visited (like in the session history).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: restrict the list to x elements → restrict the global histort list to x elements
Summary: restrict the global histort list to x elements → restrict the global history list to x elements
(Assignee)

Comment 1

18 years ago
what? This bug makes no sense. please explain what you're asking for, or I'll
mark this bug invalid.

Comment 2

18 years ago
Edit|Preferences|Navigator|History - "Expire pages in History after X days"

that's how you limit your Global history entries. Recommend wontfix/invalid.
(Reporter)

Comment 3

18 years ago
Goal is to disable the insertion of items into the list and the saving in the
text file.  The option "Expire pages..." is not relevant because it is called
only in the destructor of nsGlobalHistory and not before the insertion and the
saving.

Solutions:
----------

- check the expiration date _before_ the insert: it will solve my problem but
not for people who want to keep the list only one day (which makes sense)
- quit the AddPage method before the insertion: what I do but IMHO not the
nicest solution
- limit the size of the list (like in the Session History) to x (in my case 0)
elements

But this last solution requires some work.
(Assignee)

Comment 4

18 years ago
ok, there's already a bug about expiring entries more regularily than just on
startup/shutdown, so I'm going to say this is a dupe of that.. otherwise I'll
just mark WONTFIX.. 

*** This bug has been marked as a duplicate of 55293 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
mass-verifying Duplicate bugs which haven't changed since 2001.12.31.

set your search string in mail to "CitizenGKar" to filter out these messages.
Status: RESOLVED → VERIFIED

Updated

2 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.