crash in nsPluginInstanceOwner::InvalidateRect

RESOLVED DUPLICATE of bug 789033

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 789033
6 years ago
6 years ago

People

(Reporter: Scoobidiver (away), Assigned: johns)

Tracking

({crash, regression, topcrash})

18 Branch
All
Windows 7
crash, regression, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
It's #8 top crasher in today's build.
It first appeared in 18.0a1/20120906. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6705e131aeaa&tochange=0c4fa25f637b

Signature 	nsPluginInstanceOwner::InvalidateRect(_NPRect*) More Reports Search
UUID	ba042082-9c80-489a-b06d-4d5722120906
Date Processed	2012-09-06 20:13:47
Uptime	4861
Last Crash	9.4 weeks before submission
Install Age	1.4 hours since version was first installed.
Install Time	2012-09-06 18:52:23
Product	Firefox
Version	18.0a1
Build ID	20120906030518
Release Channel	nightly
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
Build Architecture	x86
Build Architecture Info	AuthenticAMD family 15 model 67 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x2eab8a31
App Notes 	
AdapterVendorID: 0x10de, AdapterDeviceID: 0x053e, AdapterSubsysID: 00000000, AdapterDriverVersion: 6.14.12.9573
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers+ WebGL? EGL? EGL+ GL Context? GL Context+ WebGL+ 
EMCheckCompatibility	False
Adapter Vendor ID	0x10de
Adapter Device ID	0x053e
Total Virtual Memory	2147352576
Available Virtual Memory	1426780160
System Memory Use Percentage	62
Available Page File	3470417920
Available Physical Memory	1192296448

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsPluginInstanceOwner::InvalidateRect 	dom/plugins/base/nsPluginInstanceOwner.cpp:662
1 	xul.dll 	nsNPAPIPluginInstance::InvalidateRect 	dom/plugins/base/nsNPAPIPluginInstance.cpp:1550
2 	xul.dll 	mozilla::plugins::parent::_invalidaterect 	dom/plugins/base/nsNPAPIPlugin.cpp:1123
3 	xul.dll 	mozilla::plugins::PluginInstanceParent::RecvNPN_InvalidateRect 	dom/plugins/ipc/PluginInstanceParent.cpp:566
4 	xul.dll 	mozilla::plugins::PluginInstanceParent::RecvShow 	dom/plugins/ipc/PluginInstanceParent.cpp:661
5 	xul.dll 	mozilla::plugins::PPluginInstanceParent::OnMessageReceived 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:1462
6 	xul.dll 	mozilla::plugins::PPluginModuleParent::OnMessageReceived 	obj-firefox/ipc/ipdl/PPluginModuleParent.cpp:1197
7 	xul.dll 	mozilla::ipc::SyncChannel::OnDispatchMessage 	ipc/glue/SyncChannel.cpp:143
8 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:224
9 	xul.dll 	mozilla::plugins::PPluginInstanceParent::CallPBrowserStreamConstructor 	obj-firefox/ipc/ipdl/PPluginInstanceParent.cpp:971
10 	xul.dll 	mozilla::plugins::PluginInstanceParent::NPP_NewStream 	dom/plugins/ipc/PluginInstanceParent.cpp:1417
11 	xul.dll 	mozilla::plugins::PluginModuleParent::NPP_NewStream 	dom/plugins/ipc/PluginModuleParent.cpp:608
12 	xul.dll 	nsNPAPIPluginStreamListener::OnStartBinding 	dom/plugins/base/nsNPAPIPluginStreamListener.cpp:320
13 	xul.dll 	nsPluginStreamListenerPeer::SetUpStreamListener 	dom/plugins/base/nsPluginStreamListenerPeer.cpp:1193
14 	xul.dll 	nsPluginStreamListenerPeer::OnStartRequest 	dom/plugins/base/nsPluginStreamListenerPeer.cpp:616
15 	xul.dll 	mozilla::net::nsHttpChannel::CallOnStartRequest 	netwerk/protocol/http/nsHttpChannel.cpp:969
16 	xul.dll 	mozilla::net::nsHttpChannel::InitCacheEntry 	netwerk/protocol/http/nsHttpChannel.cpp:3635
17 	nspr4.dll 	PR_GetHostByAddr 	nsprpub/pr/src/misc/prnetdb.c:1139
18 	xul.dll 	nsCookieService::SetCookieStringCommon 	netwerk/cookie/nsCookieService.cpp:1468
19 	mozglue.dll 	je_free 	memory/mozjemalloc/jemalloc.c:6575
20 	xul.dll 	nsHttpChannelAuthProvider::`scalar deleting destructor' 	
21 	xul.dll 	nsHttpChannelAuthProvider::Release 	netwerk/protocol/http/nsHttpChannelAuthProvider.cpp:1408
22 	xul.dll 	nsCOMPtr_base::assign_assuming_AddRef 	obj-firefox/dist/include/nsCOMPtr.h:440
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsPluginInstanceOwner%3A%3AInvalidateRect%28_NPRect*%29
https://crash-stats.mozilla.com/report/list?signature=nsIFrame%3A%3AGetUsedPadding%28%29
(Assignee)

Comment 1

6 years ago
might be the same cause as bug 789033
Assignee: nobody → jschoenick
Status: NEW → ASSIGNED
(Assignee)

Comment 2

6 years ago
Looks like this was fixed by backing out bug 786650

https://hg.mozilla.org/mozilla-central/rev/36427d4b2cf6

Meaning its likely a dupe of 789033
(Reporter)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
tracking-firefox18: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 789033
You need to log in before you can comment on or make changes to this bug.