Closed Bug 789546 Opened 8 years ago Closed 7 years ago

data:image gif saved as file "index" without a filename extension, no longer as file "index.gif"

Categories

(Core Graveyard :: File Handling, defect)

18 Branch
All
Android
defect
Not set

Tracking

(firefox17 unaffected, firefox18+ fixed)

RESOLVED FIXED
mozilla18
Tracking Status
firefox17 --- unaffected
firefox18 + fixed

People

(Reporter: cpeterson, Assigned: jdm)

References

()

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

This bug was forked from bug 254139 comment 62.

STR:
1. View a data:image URI such as:

data:image/gif;base64,R0lGODlhEAAOALMAAOazToeHh0tLS/7LZv/0jvb29t/f3//Ub//ge8WSLf/rhf/3kdbW1mxsbP//mf///yH5BAAAAAAALAAAAAAQAA4AAARe8L1Ekyky67QZ1hLnjM5UUde0ECwLJoExKcppV0aCcGCmTIHEIUEqjgaORCMxIC6e0CcguWw6aFjsVMkkIr7g77ZKPJjPZqIyd7sJAgVGoEGv2xsBxqNgYPj/gAwXEQA7

2. Right-click on the tiny image and `Save Image As`

AR:
Starting with Nightly 18.0a1 (2012-09-01), Firefox saves a file called "index" (with no ".gif" filename extension).

ER:
Before Nightly 2012-09-01, Firefox saved a file called "index.gif" with a proper filename extension. (The base filename is "index" because the data:image does not have its own name or title).

Here is the regression range from Nightly 08-31 to 09-01:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=fcc533f691e9&tochange=a21fd4d085ad
The first bad revision is:
changeset:   104038:bdc68f5ddb38
user:        Josh Matthews <josh@joshmatthews.net>
date:        Tue Jun 26 00:20:12 2012 -0400
summary:     Bug 722861 - Add privacy information to image requests, and use a separate cache for private requests. r=joe
Blocks: 722861
jdm, are you planning to look into this?
Yes; I've just been on a stealth vacation this week.
Assignee: nobody → josh
Argh, I totally forgot to look for JS users of the image cache and change their uses of getService.
I'm testing this patch as we speak.
Attachment #661766 - Attachment is obsolete: true
Comment on attachment 661817 [details] [diff] [review]
Convert all JS users of imgICache service to use privacy-aware imgITools API instead.

Matt, can you approve the mobile changes in this patch?
Attachment #661817 - Flags: review?(mbrubeck)
Attachment #661817 - Flags: review?(mbrubeck) → review+
Attachment #661817 - Flags: review?(ehsan) → review+
Try is green.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/27f122beb4f5
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 792700
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.