Invoking address book prevents access to other Netscape apps

VERIFIED WORKSFORME

Status

P2
major
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: scalkins, Assigned: chuang)

Tracking

({platform-parity})

Trunk
mozilla0.9.1
PowerPC
Mac System 9.x
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

(Reporter)

Description

18 years ago
Saw this Mac only
2001-05-04-09Mtrunk
(Though I believe it's been around longer than that)

Steps to repro:
1)Launch NS 6.5 browser.
2)Leave the browser up, invoke Mail. 
3)Setup Mail accounts and login to them.  
4)Invoke the Address Book and leave it's window up
5)Try to click back on the Browser or Mail window in the background

Actual results: You cannot put focus on the browser window as long as the 
address book window is up. Once you dismiss the Address Book window, you can
access the browser window.
Note: I custom installed NS 6.5 without IM.

Nominating nsbeta1, this affects IM as well.
See Bugscape Bug http://bugscape/show_bug.cgi?id=4717
(Reporter)

Updated

18 years ago
Keywords: nsbeta1
(Reporter)

Updated

18 years ago
Keywords: pp
(Reporter)

Comment 1

18 years ago
workaround, if you click on another Address book in the left upper pane, or you
clcik on a tab in the sidebar or card in the upper right pane, you can then
click on another app and access it.

Comment 2

18 years ago
marking nsbeta1+.  cc'ing danm in case he has any ideas about what could cause
this.  I saw this on the 5/2 build as well.
Priority: -- → P2
Whiteboard: [nsbeta1=]
Target Milestone: --- → mozilla0.9.1
(Reporter)

Updated

18 years ago
Whiteboard: [nsbeta1=] → [nsbeta1+]
(Assignee)

Comment 3

18 years ago
I see "Trying to position a sizeless window; caller should have called 
sizeToContent() or sizeTo(). See bug 75649."  on the console when I try to 
reproduce Bugscape Bug 4797.  Could these bugs all related?

Comment 4

18 years ago
I think Suzanne or Syd mentioned to me that this can be caused by non mail
windows.  My guess is that this is more of a Mac Window management problem than
a mail problem. Have you had any luck investigating this Candice or do we need
to reassign this or get some more help?

Comment 5

18 years ago
Esther or Suzanne, are you still seeing this in today's build?
(Reporter)

Comment 6

18 years ago
Can't repro this with todays builds
Mac 2001-05-14-04trunk
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

18 years ago
Verifying
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.