Closed Bug 789764 Opened 7 years ago Closed 7 years ago

The main menu UI obscures availability of options.

Categories

(Firefox for Android :: General, defect)

18 Branch
ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 785994

People

(Reporter: mike, Unassigned)

Details

(Keywords: uiwanted, ux-userfeedback)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.8 (KHTML, like Gecko) Chrome/23.0.1251.2 Safari/537.8

Steps to reproduce:

1. Press the hardware menu button when Firefox is open
2. See the main menu appear.
3. If you're lucky and really paying attention closely, maybe notice that a hairline scroll indicator momentarily appears on the right-hand-side of the menu, then disappears.
4. If you're not so lucky, end up staring at a main menu that seems to end with "Add-ons" and wonder where the other options are and how you can get to them.


Actual results:

See above. I thought the main menu ended at "Add-ons", because I didn't see any scroll indicator. The scroll indicator that flashes at the beginning it just not an adequate hint, especially for users with low vision -- many are just never going to notice that. And I don't even mean really low vision -- I think a lot of older users with normal age-related presbyopia are not going to notice it.


Expected results:

I should be able to easily see that there are further options available.

I realize that the UI of the current main menu and scroll-bar behavior are Android platform things. And the built-in Android browser has the problem even worse because the menu is black and the scrollbar is dark grey. But I notice the Chrome for Android gets around this somewhat by only putting only enough items on the main menu that all the items fit into screen height when you're in portrait mode.

I also notice that for whatever reason, Firefox currently doesn't start the main menu at the top of the screen. It could show 3 more items in the main menu than it does now.

Anyway, there are a lot of other apps whose main menus use a tabbed UI to group options into submenus. I think that's a better-looking UI approach and also a better user experience than the current put-all-14-menu-items into one big menu that has to be scrolled.

But I'd just be happy with any UI here that didn't have the effect of unintentionally obscuring the availability of the options that are off the bottom of the screen in the current UI.
UX, should this be marked as 'new' or duped to another bug? Thoughts?
OS: Mac OS X → Android
Hardware: x86 → ARM
This should be largely be resolved with the compact menu designs on trunk. bug 785994
(In reply to Kevin Brosnan [:kbrosnan] from comment #2)
> This should be largely be resolved with the compact menu designs on trunk.
> bug 785994

Yep. I just installed the latest Nightly and with the new compact menu, which doesn't have this problem. So I think this bug can probably be moved to resolved.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 785994
You need to log in before you can comment on or make changes to this bug.