Closed Bug 789837 Opened 7 years ago Closed 7 years ago

Firefox and Thunderbird linux32 l10n nightlies busted - fatal error: opening dependency file .deps/elf-dynstr-gc.pp in make config

Categories

(Firefox Build System :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla18

People

(Reporter: nthomas, Assigned: glandium)

References

Details

Attachments

(1 file)

eg http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-l10n/1347189653.1347189770.20729.gz&fulltext=1

make
 in dir /builds/slave/m-cen-lnx-l10n-ntly/build/mozilla-central/config (timeout 1200 secs)
gcc  -DMOZ_GLUE_IN_PROGRAM  -I../config -I. -I../dist/include  -I/builds/slave/m-cen-lnx-l10n-ntly/build/mozilla-central/dist/include/nspr -I/builds/slave/m-cen-lnx-l10n-ntly/build/mozilla-central/dist/include/nss      -fPIC  -pedantic -Wall -Wpointer-arith -Wdeclaration-after-statement -Wno-unused -Wcast-align -Wno-long-long -fno-strict-aliasing -ffunction-sections -fdata-sections -pthread -pipe  -DNDEBUG -DTRIMMED -g -O3 -fomit-frame-pointer   -include ../mozilla-config.h -DMOZILLA_CLIENT -MD -MF .deps/elf-dynstr-gc.pp -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -o elf-dynstr-gc elf-dynstr-gc.c -lpthread  -Wl,-z,noexecstack   -Wl,-rpath-link,/builds/slave/m-cen-lnx-l10n-ntly/build/mozilla-central/dist/bin -Wl,-rpath-link,/usr/local/lib  -L/lib -lgobject-2.0 -lglib-2.0   
elf-dynstr-gc.c:1209: fatal error: opening dependency file .deps/elf-dynstr-gc.pp: No such file or directory
compilation terminated.
make: *** [elf-dynstr-gc] Error 1
program finished with exit code 2

The nightlies of the 7th worked, failing like this from the 8th. A clobber was set during the 7th (RyanVM says for a mozbase udpate) and the builds of the 8th would have picked this up, so I suspect the bustage is due to an earlier landing that still worked in dep builds.
Duplicate of this bug: 789794
Testing on try:
https://tbpl.mozilla.org/?tree=Try&rev=7f6534716c46

Considering NEED_MDDEPDIR is only used in three places, i figured it could go away as well. The surprising thing is that it didn't break earlier.
Attachment #659665 - Flags: review?(ted.mielczarek)
Assignee: nobody → mh+mozilla
Comment on attachment 659665 [details] [diff] [review]
Properly set dependencies on .deps directories

Review of attachment 659665 [details] [diff] [review]:
-----------------------------------------------------------------

Only sort of related, but do we even need elf-dynstr-gc anymore?

::: config/Makefile.in
@@ +143,1 @@
>  	$(CC) $(COMPILE_CFLAGS) $(GLIB_CFLAGS) -o $@ $< $(LDFLAGS) $(GLIB_LIBS) 

Can you remove the trailing space while you're here?
Attachment #659665 - Flags: review?(ted.mielczarek) → review+
https://hg.mozilla.org/mozilla-central/rev/c8e5053af5ad
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Duplicate of this bug: 790385
Blocks: 911924
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.