Last Comment Bug 789964 - Root usage in updater scares users, doesn't work
: Root usage in updater scares users, doesn't work
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 18
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
Mentors:
: 789534 (view as bug list)
Depends on:
Blocks: 789534
  Show dependency treegraph
 
Reported: 2012-09-10 09:22 PDT by James Willcox (:snorp) (jwillcox@mozilla.com)
Modified: 2012-09-20 14:30 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Always use Android install wizard for updates (9.45 KB, patch)
2012-09-10 09:23 PDT, James Willcox (:snorp) (jwillcox@mozilla.com)
mark.finkle: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-10 09:22:34 PDT
We've had some users get a little freaked out when Nightly requests root access to do an update. In addition, the 'pm install' method of updating doesn't actually work, it seems, even though it reports success. We should just remove all of that and use the crappy Android install wizard in all cases.
Comment 1 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-10 09:23:37 PDT
Created attachment 659743 [details] [diff] [review]
Always use Android install wizard for updates
Comment 2 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-10 10:55:43 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/c675ef1daee1
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-09-10 18:45:21 PDT
https://hg.mozilla.org/mozilla-central/rev/c675ef1daee1
Comment 4 Reed Loden [:reed] (use needinfo?) 2012-09-12 11:18:23 PDT
*** Bug 789534 has been marked as a duplicate of this bug. ***
Comment 5 James Willcox (:snorp) (jwillcox@mozilla.com) 2012-09-17 08:32:49 PDT
Comment on attachment 659743 [details] [diff] [review]
Always use Android install wizard for updates

[Approval Request Comment]
Necessary dependency for bug 786380
Comment 6 Scoobidiver (away) 2012-09-20 14:30:44 PDT
Pushed to Aurora: http://hg.mozilla.org/releases/mozilla-aurora/rev/b0ca21422a15

Note You need to log in before you can comment on or make changes to this bug.