Add a way to make a DELETE call on the request API

RESOLVED DUPLICATE of bug 643156

Status

Add-on SDK
General
P3
normal
RESOLVED DUPLICATE of bug 643156
6 years ago
6 years ago

People

(Reporter: peregrino, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

It's possible to make POST, GET, and PUT requests with the request API, but not DELETE.
No HEAD of TRACE either presumably. It might make sense to just have a request(type) method to cover all the other less-used methods.
You mean additionally to adding a .delete() method or just use this request(type) for DELETE and all the rest?
(In reply to Hernán Rodriguez Colmeiro (:peregrino) from comment #2)
> You mean additionally to adding a .delete() method or just use this
> request(type) for DELETE and all the rest?

The latter would be my suggestion, I'd probably prefer to use that for PUT too but since it already exists there isn't much point in breaking it now.

Updated

6 years ago
Priority: -- → P3
Bug 643156 has a patch to add DELETE.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 643156
You need to log in before you can comment on or make changes to this bug.