Closed Bug 790050 Opened 8 years ago Closed 8 years ago

Windows console used to launch Firefox will not exit

Categories

(Firefox :: Untriaged, defect)

15 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 787313

People

(Reporter: v+mozbug, Unassigned)

Details

Attachments

(1 file)

Attached file setup_test.cmd
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

Placed following two lines in batch file and ran it (batch file attached setup_test.cmd)

start "Firefox" "C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
pause

Batch file started firefox, gave "press enter to continue..." prompt.
I pressed enter.


Actual results:

Console scrolled and moved cursor to left edge of window.

Closing the console with the red X (close box) causes Firefox to be terminated.

Alternately, closing Firefox with its red X allows the console window to finally disappear.


Expected results:

Console should have exited.  The CMD prompt exited (per Windows Task Manager), but not the Console window.  There should be no connection between the started Firefox and the console window, when Firefox is launched with the start command, in my understanding (and prior behavior).

Initial testing was on Win7, but tweaked the batch file and the same thing happens on XP, with FF 15.0.1. This seems to be a new behavior in FF 15.0.1, but I skipped 15.0.0 because I was traveling, so could have started in that version. Also happens in XP (tweaked the path to Firefox and tested on my wife's old XP laptop). Also happens with Thunderbird 15.0 (so probably in common infrastructure). Also happens with a much larger batch file with many other lines executed and programs launched between the two lines in the test case, so it took a while to isolate it.  Also happens if the "pause" command is replaced by a Python script that emulates pause, so I don't think it is new semantics for pause. Also happens if the first line is typed at a CMD prompt. Also happens if many nested CMD prompts are launched in the same console window, then the batch file or command is run, and then all the nested and the outer CMD prompt is exited... the console window still stays, the CMD all go away.

Does not happen if the pause command is removed from the batch file, and the batch file is launched from the Start menu... so it seems that somehow the console must be an interactive console, with input operations performed from it, for the symptom to occur.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787313
You need to log in before you can comment on or make changes to this bug.