Incorrect address bar autocomplete behaviour

RESOLVED DUPLICATE of bug 765337

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 765337
5 years ago
5 years ago

People

(Reporter: sheikin.igor, Unassigned)

Tracking

15 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:15.0) Gecko/20100101 Firefox/15.0
Build ID: 20120825192204

Steps to reproduce:

Visit URLs:
http://opennet.ru/
http://www.opennet.ru/
or
http://overclocker.ru/
http://www.overclocker.ru/

After that write in address bar first few chars "open" (or "over")


Actual results:

Autocompletion shows address "opennet.ru/" (or "overclocker.ru") 
after that URL which loaded are "http://www.opennet.ru" (or "http://www.overclocker.ru")

And does not matter what URLs with "www." are visited 100times less often when URLs without it.


Expected results:

Work of autocompletion should result in loading following URLs
"http://opennet.ru" (or "http://overclocker.ru")

So it seems that addition of "www." to the address is general rule, if there are exist such URL. 

(Chromium, Opera, Safari do not have such a problem)
(Reporter)

Updated

5 years ago
OS: Linux → All
Hardware: x86_64 → All
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 765337
You need to log in before you can comment on or make changes to this bug.