Only the view-port is changed after requesting the desktop side of a webpage

NEW
Unassigned

Status

()

Firefox for Android
General
5 years ago
2 years ago

People

(Reporter: xti, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox17 affected, firefox18 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 660051 [details]
screenshot

Firefox 18.0a1 (2012-09-11)
Device: Galaxy Note
OS: Android 4.0.4

Steps to reproduce:
1. Open Fennec
2. Open http://goo.gl/ycxWw
3. Tap on Menu > Request Desktop Site

Expected result:
Desktop version of the page opened at step 2 is displayed.

Actual result:
Mobile page is still displayed after step 3, but the view-port is changed like for a desktop page, as you can see in the attached screenshot.
Created attachment 660066 [details]
WFM (Nightly 09/11)

WFM.
(Reporter)

Comment 2

5 years ago
I used to get this issue just after I do some browsing. Also, after it occurs once, then will never occur on the same profile, or at least I couldn't reproduce it again until I cleaned the Nightly Data.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

5 years ago
This issue is reproducible even on Aurora build. As you can see in the following video, this bug is always reproducible on a clean profile: http://youtu.be/v8dEsaQvaxA
--
Firefox 17.0a2 (2012-09-11)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → REOPENED
status-firefox17: --- → affected
status-firefox18: --- → affected
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

5 years ago
Note: If Request Desktop site option is disabled and then enabled again, the Desktop page is loaded as expected.

Updated

5 years ago
Duplicate of this bug: 785479
(Reporter)

Comment 6

5 years ago
I guess that the same issue occurs if Desktop Site is requested for mobil.tagesschau.de.

--

Firefox 18.0a1 (2012-09-25)
Device: Galaxy Note
OS: Android 4.0.4
Status: REOPENED → NEW
You need to log in before you can comment on or make changes to this bug.