Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Inaccurate System Requirements for Windows Server 2003

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Nick Lowe, Assigned: akeybl)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20120904124322

Steps to reproduce:

Read the release notes for Firefox 13, 14 and 15.

http://www.mozilla.org/en-US/firefox/13.0/system-requirements/
http://www.mozilla.org/en-US/firefox/14.0/system-requirements/
http://www.mozilla.org/en-US/firefox/15.0/system-requirements/


Actual results:

Firefox requires SP1 for Windows Server 2003 to be installed as of Firefox 13. This is for the same reason that SP2 is required for Windows XP.

This is not mentioned in the release notes so they are inaccurate.


Expected results:

Firefox should have accurate system requirements in its release notes.
(Reporter)

Updated

5 years ago
Component: Untriaged → General
OS: Mac OS X → Windows Server 2003
Hardware: x86 → All
This isn't a "general" issue, not even a "firefox" one since it's an issue on the website. Please leave bugs in "untriaged", thanks !
Component: General → Pages & Content
Product: Firefox → www.mozilla.org
Version: 15 Branch → unspecified
IsWow64Process() is being called at:
http://mxr.mozilla.org/mozilla-central/source/netwerk/protocol/http/nsHttpHandler.cpp#676

Minimum system requirement for IsWow64Process() is W2K3 SP1:
http://msdn.microsoft.com/en-us/library/windows/desktop/ms684139%28v=vs.85%29.aspx
(Assignee)

Updated

5 years ago
Assignee: nobody → akeybl
(Reporter)

Comment 3

5 years ago
The compiler being used for the Windows build now emits EncodePointer and DecodePointer calls, which requires Server 2003 SP1:

http://msdn.microsoft.com/en-us/library/bb432254%28v=vs.85%29.aspx

http://msdn.microsoft.com/en-us/library/bb432242%28v=vs.85%29.aspx

It's definitely a requirement at this point.
(Reporter)

Updated

5 years ago
Depends on: 563318
(Assignee)

Comment 4

5 years ago
http://viewvc.svn.mozilla.org/vc?view=revision&revision=113127
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.