Closed Bug 790228 Opened 8 years ago Closed 8 years ago

Inaccurate System Requirements for Windows Server 2003

Categories

(www.mozilla.org :: Pages & Content, defect)

All
Windows Server 2003
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nick, Assigned: akeybl)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20120904124322

Steps to reproduce:

Read the release notes for Firefox 13, 14 and 15.

http://www.mozilla.org/en-US/firefox/13.0/system-requirements/
http://www.mozilla.org/en-US/firefox/14.0/system-requirements/
http://www.mozilla.org/en-US/firefox/15.0/system-requirements/


Actual results:

Firefox requires SP1 for Windows Server 2003 to be installed as of Firefox 13. This is for the same reason that SP2 is required for Windows XP.

This is not mentioned in the release notes so they are inaccurate.


Expected results:

Firefox should have accurate system requirements in its release notes.
Component: Untriaged → General
OS: Mac OS X → Windows Server 2003
Hardware: x86 → All
This isn't a "general" issue, not even a "firefox" one since it's an issue on the website. Please leave bugs in "untriaged", thanks !
Component: General → Pages & Content
Product: Firefox → www.mozilla.org
Version: 15 Branch → unspecified
Assignee: nobody → akeybl
The compiler being used for the Windows build now emits EncodePointer and DecodePointer calls, which requires Server 2003 SP1:

http://msdn.microsoft.com/en-us/library/bb432254%28v=vs.85%29.aspx

http://msdn.microsoft.com/en-us/library/bb432242%28v=vs.85%29.aspx

It's definitely a requirement at this point.
Depends on: msvc2010
http://viewvc.svn.mozilla.org/vc?view=revision&revision=113127
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.