If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Wifi] Expand scan result flag

RESOLVED DUPLICATE of bug 791506

Status

Firefox OS
General
--
enhancement
RESOLVED DUPLICATE of bug 791506
5 years ago
4 years ago

People

(Reporter: Masashi Honma, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
The flag area in scan result contains some useful information.
But current code uses only encryption mode.

This patch makes Gecko send all flags to Gaia.

I will use these flags to obtain WPS information.
(Reporter)

Comment 1

5 years ago
Created attachment 660064 [details] [diff] [review]
Patch file of this bug
(Reporter)

Comment 2

5 years ago
After this patch will be landed.

The pull request #4564 for Gaia needs to be landed.
(Reporter)

Comment 3

5 years ago
Is there any comment on this ?

If you could not understand why this patch is needed, see pull request #5066 for Gaia.
(Reporter)

Comment 4

5 years ago
Hello, Blake Kaplan.

If you have time, could you review this patch and Bug 791506 ?

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 660064 [details] [diff] [review]
Patch file of this bug

I am very much against this patch. Doing this ties the API very directly to wpa_supplicant. Looking at the pull request, why can't you simply add WPS to the list of capabilities (note that gaia will probably have to change to take that into account)?
Attachment #660064 - Flags: review-
(Reporter)

Comment 6

5 years ago
> why can't you simply add WPS to the list of capabilities ?

First time, I have thought like you. But wpa_supplicant flags information has more useful information except WPS flags. For example "ESS flag".

If I only pass the WPS flag, I must change Gecko when I need to use another wpa_supplicant flag.

If I pass the all flags to Gaia, Gecko doesn't need more change about flags. I think changing Gecko has more impact than changing Gaia. Because Gecko is working on many platforms. So I think this patch is better way to reduce future code changes.

If changing Gecko for every flag addition is acceptable, I will change my patch as you say.
(Reporter)

Comment 7

5 years ago
I made a new patch only changes WPS flag.
See new patch in Bug 791506.
(Reporter)

Comment 8

5 years ago
Created attachment 666997 [details] [diff] [review]
Patch after review
Attachment #660064 - Attachment is obsolete: true
(Reporter)

Updated

5 years ago
Flags: sec-review?
(Reporter)

Updated

5 years ago
Flags: sec-review?
(Reporter)

Updated

5 years ago
Attachment #666997 - Flags: review?(mrbkap)
Comment on attachment 666997 [details] [diff] [review]
Patch after review

Review of attachment 666997 [details] [diff] [review]:
-----------------------------------------------------------------

I like this patch except for the name of the new property.

How does "security" instead of "encryptions" sound to you? Kaze, I'd appreciate your suggestion as well.
Attachment #666997 - Flags: review?(mrbkap)
`encryptions' is misleading, I'd prefer `security' as well.
(Reporter)

Comment 11

5 years ago
Created attachment 667462 [details] [diff] [review]
Patch after review 2
Attachment #666997 - Attachment is obsolete: true
(Reporter)

Comment 12

5 years ago
> `encryptions' is misleading, I'd prefer `security' as well.

I modified my patch.
Comment on attachment 667462 [details] [diff] [review]
Patch after review 2

Is there a pull request ready to go on the gaia side so we can check this in without breaking things? This is ready to go with that.
Attachment #667462 - Flags: review+
https://github.com/mozilla-b2g/gaia/pull/5528
(Reporter)

Comment 15

5 years ago
> Is there a pull request ready to go on the gaia side so we can check this in
> without breaking things? This is ready to go with that.

I updated my PR #5528.
Comment on attachment 667462 [details] [diff] [review]
Patch after review 2

https://hg.mozilla.org/integration/mozilla-inbound/rev/8321d22a0957
Hello Masashi-san,

I'm very sorry, but I had to back out this patch :(.  The gaia pull request was not merged in time, and without this patch breaks wifi.

We need to work with kaze to get the pull request merged.

https://hg.mozilla.org/integration/mozilla-inbound/rev/c924b386e2ea
(Reporter)

Comment 18

5 years ago
OK. I will re-write the patch for master branch, and re-send it in few hours.
(Reporter)

Comment 19

5 years ago
I re-wrote. See new PR #5697.
Looks like Masashi attached a fix for this bug in the patch he proposes for bug 791506. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791506
You need to log in before you can comment on or make changes to this bug.