Click-to-play doesn't load Flowplayer when the <a> tag to include the video file contains an element (like splash image)

RESOLVED DUPLICATE of bug 787619

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 787619
6 years ago
6 years ago

People

(Reporter: Loic, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
STR:
Be sure click-to-play is enabled in Nightly.

1) Open the demo 'Flowplayer Minimal Setup' (http://flowplayer.org/demos/standalone/installation/index.html) and click to play.
More info about the code: http://flowplayer.org/demos/installation/index.html

2) Open the demo 'Initial splash image' (http://flowplayer.org/demos/standalone/installation/splash-image.html) and click to play.
More info about the code: http://flowplayer.org/demos/installation/splash-image.html

Result:
In the 1st case, Flowplayer is loaded and the video is played after clicking to play.
In the 2nd case, Flowplayer isn't loaded and the click-to-play overlay comes back each time the user clicks to enable it.

The difference is in the code to include the video file.
1st case:
<!-- player container-->
<a href="http://pseudo01.hddn.com/vod/demo.flowplayervod/flowplayer-700.flv"    class="player"
    style="display:block;width:425px;height:300px;margin:10px auto"
    id="player">
</a>

2nd case:
<!-- player container-->
<a href="http://pseudo01.hddn.com/vod/demo.flowplayervod/flowplayer-700.flv"    class="player"
    style="display:block;width:425px;height:300px;margin:10px auto"
    id="player">
    <!-- specify a splash image inside the container -->
<img
    src="/media/img/home/flow_eye.jpg"
    alt="Search engine friendly content" />
</a>

NB: Replacing the <img> by a comment <!-- --> is enough to block Flowplayer to load.
(Reporter)

Updated

6 years ago
Blocks: 738698
Is this the same as bug 787619, or is this a related but different issue?
(Reporter)

Comment 2

6 years ago
Yes, same bug indeed (but the title is not very meaningful).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 787619
You need to log in before you can comment on or make changes to this bug.