Can't upload PNG to wiki

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: gene, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 660156 [details]
failing wiki.mozilla.org image upload

When I go to this page :

https://wiki.mozilla.org/Special:Upload

and attempt to upload the attached image, I get the error message "File extension does not match MIME type."

I've recreated the image in gimp to confirm that it's a valid PNG and it is. What is causing this?
(Reporter)

Comment 1

6 years ago
Just had to do this again with a different PNG. Same failure.
(Reporter)

Comment 2

6 years ago
Just talked to solarce. Looks like the cause is that the two filenames must match :

https://skitch.com/solarce/8t58h/upload-file-mozillawiki
(Reporter)

Comment 3

6 years ago
I've made a patch to clarify this here : Bug 804412
Depends on: 804412
(Reporter)

Comment 4

6 years ago
As of the current version of mediawiki installed ( https://wiki.mozilla.org/Special:Version ) 1.19.4, filenames can now differ and this patch is no longer needed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.