Default setting dom.ipc.plugins.flash.subprocess.crashreporter.enabled in Firefox 15 causes crash in Flash player plugin

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: vilee, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

15 Branch
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

Launch any Flash-enabled web page in Firefox 15, such as youtube.com


Actual results:

Firefox reports that Flash player has crashed.


Expected results:

Flash player plugin should not have crashed and should function normally. This problem is new in Firefox 15, the previous Firefox version 14.0.1 doesn't have this problem.
(Reporter)

Comment 1

6 years ago
about:config > Setting dom.ipc.plugins.flash.subprocess.crashreporter.enabled to false will workaround this crash.
(Reporter)

Updated

6 years ago
Crash Signature: F1398665248
Component: Untriaged → IPC
Product: Firefox → Core
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

6 years ago
Do you have Trusteer Rapport installed? We have a known issue with an old version of Trusteer Rapport which was hooking Firefox functions poorly and caused a Flash crash of this sort.
Component: IPC → Plug-ins

Comment 4

6 years ago
FWIW, this doesn't appear to be a hang, just a crash. Are you actually experiencing a hang?
(Reporter)

Comment 5

6 years ago
Yes, this is a crash, not a hang. Summary has been corrected, it may have been a typo.
Summary: Default setting dom.ipc.plugins.flash.subprocess.crashreporter.enabled in Firefox 15 causes hang in Flash player plugin → Default setting dom.ipc.plugins.flash.subprocess.crashreporter.enabled in Firefox 15 causes crash in Flash player plugin
(Reporter)

Comment 6

6 years ago
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #3)
> Do you have Trusteer Rapport installed? We have a known issue with an old
> version of Trusteer Rapport which was hooking Firefox functions poorly and
> caused a Flash crash of this sort.

No, I don't have Trusteer Rapport installed. Searching for Trusteer Rapport in All Programs and Firefox > Add-ons Manager returned no match.

Comment 7

6 years ago
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Blocks: 774281
Severity: normal → critical
Crash Signature: F1398665248 → [@ F1398665248_____________________________ ]
Keywords: crash
Hardware: x86_64 → x86

Comment 9

6 years ago
If you disable Flash HW acceleration (see https://support.mozilla.org/kb/flash-video-wont-play-full-screen#w_disable-flash-hardware-acceleration), does it still happen?
If you temporarily disable your antivirus/firewall, does it still happen?
(Reporter)

Comment 10

6 years ago
Still happens with Flash player HW acceleration disabled.

With McAfee On-Access Scan disabled, Firefox does not report Flash player crashing, but it seems to be starting/shutting down/restarting Flash player every second. As a result, the Flash content area remains blank during this repeated sequence.

Comment 11

6 years ago
Did you set previously (before the update to Firefox 15) dom.ipc.plugins.enabled to false?
Try to completely disable McAfee for the test.
(Reporter)

Comment 12

6 years ago
My setting for dom.ipc.plugins.enabled has always been the default (true) before and after the Firefox 15 update.

With McAfee disabled completely (all the following tasks in VirusScan Console), Firefox now reports Flash player has crashed.
* Disabled Access Protection
* Disabled On-Delivery Email Scanner
* Disabled On-Access Scanner
(Reporter)

Comment 14

6 years ago
Still the same behavior after uninstalling/reinstalling Flash player.
https://crash-stats.mozilla.com/report/index/0df796fd-6b36-4989-b133-4641b2120912

Comment 15

6 years ago
There's third-party software that always runs on your computer that causes that. You must find out which one.
(Reporter)

Comment 16

6 years ago
After further investigation, we have determined that this is not a Firefox issue and can be closed as resolved.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.