Closed Bug 790461 Opened 12 years ago Closed 9 years ago

Integration of add-ons and webapps

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), enhancement, P3)

ARM
Android
enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: cscott, Unassigned)

Details

(Keywords: productwanted, Whiteboard: [WebRuntime] [blocking-webrtandroid1-])

Webapps can use add-ons to access parts of the native SDK which are not yet exposed via HTML5 interfaces.  One can imagine a "PhoneGap" add-on, for example.  I am also writing educational apps which log assessments via the funf.org framework in Android; https://github.com/cscott/intent-addon is an add-on which exposes this to page scripts.

Currently the reslution of bug 766297 has disabled all access to add-ons from web apps.  There should be a mechanism to allowed controlled use of add-ons.

I suggest a "dependencies" and "optional dependencies" be specified in the webapp manifest, which specify add-ons which *must* or *may* be installed.  For optional dependencies, they should be installable via scripts in the webapp itself, since the traditional firefox addons menu will not be present.
OS: Linux → Gonk
Hardware: x86 → ARM
OS: Gonk → Android
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Severity: normal → enhancement
Whiteboard: [blocking-webrtandroid1-]
Keywords: productwanted
Whiteboard: [blocking-webrtandroid1-] → [WebRuntime] [blocking-webrtandroid1-]
Per bug 1235869, we're going to disable the Android web runtime, so we won't fix this bug in it.

(This is part of a bulk resolution of bugs in the Firefox for Android::Web Apps component, from which I attempted to exclude bugs that are not specific to the runtime, but it's possible that I included one accidentally.  If so, I'm sorry, and please reopen the bug!)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WONTFIX
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.