Closed Bug 790553 Opened 8 years ago Closed 8 years ago

Increase the timeout when connecting to Firefox for Android from the Remote Debugger

Categories

(DevTools :: Debugger, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 18

People

(Reporter: sole, Assigned: vporof)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1

Steps to reproduce:

Entered the Android ip address and port, pressed OK. Then left the keyboard and went to the phone which was a little bit away from the keyboard, and pressed "OK" to allow the remote debugger to connect.


Actual results:

The remote debugger had given up already and I had to restart the process again and be FASTER!


Expected results:

The remote debugger should wait longer because I only have two hands and two eyes, so I can't be typing in the keyboard and looking at the screen while looking at and holding the phone ready to hit the OK button as soon as the dialog pops up. The defaults allow users for only THREE seconds to react!

A brilliant demonstration of this comes from none other than Kevin Dangoor, in the video that demonstrates the remote debugger. Kevin must have done that many times already, but still fails to connect to the debugger in the video because he takes a little longer to hit the OK button:
http://youtu.be/Znj_8IFeTVs?t=4m39s

I guess a safer default timeout should be 20? 30 seconds? I've manually set devtools.debugger.remote-timeout to 30000 (30 secs) and the experience is way more relaxed and less stressful :-)
Component: Untriaged → General
Product: Firefox → Firefox for Android
Version: 15 Branch → unspecified
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → ASSIGNED
Component: General → Developer Tools: Debugger
OS: Linux → All
Product: Firefox for Android → Firefox
Hardware: x86_64 → All
Assignee: nobody → vporof
Attached patch v1Splinter Review
Banana.
Attachment #665509 - Flags: review?(past)
Comment on attachment 665509 [details] [diff] [review]
v1

Review of attachment 665509 [details] [diff] [review]:
-----------------------------------------------------------------

20' it is then.
Attachment #665509 - Flags: review?(past) → review+
https://hg.mozilla.org/mozilla-central/rev/0c8442db91fe
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 18
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.