Last Comment Bug 790614 - Report broken site when Request Desktop Site is used
: Report broken site when Request Desktop Site is used
Status: RESOLVED DUPLICATE of bug 1024807
: uiwanted
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 15 Branch
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 06:53 PDT by Lawrence Mandel [:lmandel] (use needinfo)
Modified: 2014-10-28 08:51 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP patch (1.51 KB, patch)
2012-09-12 09:03 PDT, Brad Lassey [:blassey] (use needinfo?)
no flags Details | Diff | Splinter Review
patch (4.68 KB, patch)
2012-09-13 04:39 PDT, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review-
Details | Diff | Splinter Review
java API for doorhangers (5.67 KB, patch)
2012-09-13 04:39 PDT, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review-
Details | Diff | Splinter Review

Description Lawrence Mandel [:lmandel] (use needinfo) 2012-09-12 06:53:12 PDT
As discussed in bug 788921#c10, we expect Request Desktop Site will be used for sites that serve broken/unusable mobile content to Firefox for Android. In this case the "desktop" site is preferable over the mobile site. blassey had a great idea to send data on the URL for which users are clicking on Request Desktop Site. We can use this data to target specific sites for investigation and evangelism. I would like to request a mechanism to submit the URL for which a user has clicked on Request Desktop Site.
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2012-09-12 09:03:10 PDT
Created attachment 660465 [details] [diff] [review]
WIP patch
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2012-09-13 04:39:06 PDT
Created attachment 660792 [details] [diff] [review]
patch
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2012-09-13 04:39:45 PDT
Created attachment 660793 [details] [diff] [review]
java API for doorhangers
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2012-09-13 05:29:29 PDT
The thinking here is a user must think the mobile site is broken to want to use "desktop mode" on their phone?

I'd like to get some UX input here too. I'm not 100% sure we want a doorhanger showing each time you turn on the "desktop mode". Also remember that "desktop mode" is not per-site, it's per-tab, so any site loaded into the tab after "desktop mode" is set will get the desktop UA.

Lastly, on tablets using "desktop mode" might not mean a site is broken, but might mean the user wants the desktop site because the tablet screen size allows it to be used.
Comment 5 Lawrence Mandel [:lmandel] (use needinfo) 2012-09-13 05:36:55 PDT
(In reply to Mark Finkle (:mfinkle) from comment #4)
> The thinking here is a user must think the mobile site is broken to want to
> use "desktop mode" on their phone?

Yes.

> I'd like to get some UX input here too. I'm not 100% sure we want a
> doorhanger showing each time you turn on the "desktop mode". 

Agreed. This is a concern that we need to address.

> Also remember
> that "desktop mode" is not per-site, it's per-tab, so any site loaded into
> the tab after "desktop mode" is set will get the desktop UA.

That's a good point. However, we don't have to be perfect with this feature. It is just meant to provide some input to the evangelism effort as to sites for which our users prefer the desktop content so that we can try to "fix" their experience. Showing the door hangar on the first click and not on subsequent site visits should be ok.

> Lastly, on tablets using "desktop mode" might not mean a site is broken, but
> might mean the user wants the desktop site because the tablet screen size
> allows it to be used.

Is there some way to restrict this feature to mobile phones only?
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-09-13 06:06:59 PDT
(In reply to Mark Finkle (:mfinkle) from comment #4)
> The thinking here is a user must think the mobile site is broken to want to
> use "desktop mode" on their phone?
The thinking is user requesting the desktop site is an indication that they're not happy with what the site served them by default and we should prompt them to report it so our evangelism team can investigate.

> 
> I'd like to get some UX input here too. I'm not 100% sure we want a
> doorhanger showing each time you turn on the "desktop mode". Also remember
> that "desktop mode" is not per-site, it's per-tab, so any site loaded into
> the tab after "desktop mode" is set will get the desktop UA.
I don't think this really matters. The door hanger only comes down when the user makes the request, indicating they're unhappy with the content they're currently seeing. Continuing to browse with a tab that is in "request desktop site mode" will not show any more door hangers.


> Lastly, on tablets using "desktop mode" might not mean a site is broken, but
> might mean the user wants the desktop site because the tablet screen size
> allows it to be used.

I don't see why tablet would be any different. The user got content that wasn't meeting their expectations, such as getting a crappy WAP site with a tablet. Our evangelism team can use that report to ensure that tablets get good content by default.
Comment 7 Mark Finkle (:mfinkle) (use needinfo?) 2012-09-13 06:12:31 PDT
(In reply to Brad Lassey [:blassey] from comment #6)

> I don't see why tablet would be any different. The user got content that
> wasn't meeting their expectations, such as getting a crappy WAP site with a
> tablet. Our evangelism team can use that report to ensure that tablets get
> good content by default.

It doesn't need to be a crappy WAP site for a tablet user to want the desktop site. It could be a beautiful mobile site. I still might want to see the desktop site.

I still want UX to chime in.
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2012-09-13 06:14:50 PDT
(In reply to Mark Finkle (:mfinkle) from comment #7)
> (In reply to Brad Lassey [:blassey] from comment #6)
> 
> > I don't see why tablet would be any different. The user got content that
> > wasn't meeting their expectations, such as getting a crappy WAP site with a
> > tablet. Our evangelism team can use that report to ensure that tablets get
> > good content by default.
> 
> It doesn't need to be a crappy WAP site for a tablet user to want the
> desktop site. It could be a beautiful mobile site. I still might want to see
> the desktop site.
A beautiful mobile site being served to a tablet is still something we may want o get the evangelism team involved in. The fact that the user requested the desktop site still indicates they were unhappy with it.

> I still want UX to chime in.
Never anything wrong with that.
Comment 9 Aaron Train [:aaronmt] 2012-09-13 06:51:24 PDT
There's also folks who simply wish to treat their mobile browser as yet another desktop client and opt to browse with it perpetually enabled as determined from Google Play feedback.
Comment 10 Ian Barlow (:ibarlow) 2012-09-13 07:10:07 PDT
Can someone explain to me what this doorhanger I'm reading about would do? My kneejerk reaction would be absolutely do *not* hit a user with a doorhanger every time they turn request desktop site on. I'm not convinced the only time people use it is when a site is broken or unusable -- sometimes they might just prefer one version over the other.
Comment 11 Ian Barlow (:ibarlow) 2012-09-13 08:59:01 PDT
Ok, so it sounds like there are a couple of things happening here. 

1. We want to provide the best content without a "request desktop site" feature, since this is perceived as a "hacky" way of doing things. 
2. We want to encourage website developers to improve the content they send us

I understand the desire to get our users to help us understand what's not working on sites that makes them try to switch to desktop mode, but I'm not convinced that a doorhanger asking for feedback is the most appropriate way of getting that information. 

I actually think it would be an extremely annoying experience most of the time. What if you just genuinely prefer the desktop version of the New York Times, and don't care if you have to pinch and pan around to read it? What if I just don't like the searching and shopping experience on mobile Amazon and would prefer to use the desktop one instead? Sure, I can switch this from within the site, but as a user I am probably not making any distinction between that and the Request Desktop Site item in the Firefox menu. Hacky or not, it's actually a pretty useful thing to have.

---

Having said that, I agree we can still encourage developers with crappy mobile websites to do better. But what about just automatically sending information to Mozilla, whenever Request Desktop Site is turned on and off. At least we could start to look for patterns around when and where it's happening most often. Would something like that fall under the umbrella of the "Send info to Mozilla so that we can improve Firefox?" opt in prompt when you first install Firefox?
Comment 12 Lawrence Mandel [:lmandel] (use needinfo) 2012-09-25 08:18:50 PDT
(In reply to Ian Barlow (:ibarlow) from comment #11)
> Having said that, I agree we can still encourage developers with crappy
> mobile websites to do better. But what about just automatically sending
> information to Mozilla, whenever Request Desktop Site is turned on and off.
> At least we could start to look for patterns around when and where it's
> happening most often. Would something like that fall under the umbrella of
> the "Send info to Mozilla so that we can improve Firefox?" opt in prompt
> when you first install Firefox?

I would like to automatically send this data back without annoying our users. However, I think that URLs falls into the personal data bucket and is not covered by our Telemetry prompt. (As a point of reference, Telemetry sends no URLs in its data packet even thought these have the potential to benefit our diagnosis process.) We can consider a single prompt to opt-in to this type of data collection but, as we've seen with other solutions, opt-in rates are typically pretty low.
Comment 13 Lawrence Mandel [:lmandel] (use needinfo) 2012-10-03 07:29:47 PDT
If we don't want to prompt users for this feedback, can we take a less invasive approach and add a "Submit broken site" menu item that kicks off the same action?
Comment 14 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-24 14:34:50 PDT
Comment on attachment 660792 [details] [diff] [review]
patch

Let's go back to UX and figure out if this is the best approach. Maybe we shold be looking at adding this to the Feedback system somehow.
Comment 15 Mark Finkle (:mfinkle) (use needinfo?) 2012-10-24 14:36:16 PDT
Assigning to Ian, but he can move to someone else. Let's see how we can fit this into our feedback system.
Comment 16 Lawrence Mandel [:lmandel] (use needinfo) 2012-11-05 12:54:32 PST
Found this link today about how we reported broken sites back in FF2.0:

http://browsers.about.com/od/fire3/ss/macfirefoxdefec.htm
Comment 17 Mike Taylor [:miketaylr] 2014-10-28 08:51:30 PDT
Going to resolve this as a dupe of bug 1024807, which added this functionality for Nightly users. Requesting Desktop Site will show a toast prompting to "Report Site Issue?"

*** This bug has been marked as a duplicate of bug 1024807 ***

Note You need to log in before you can comment on or make changes to this bug.