B2G browser renders Google.com with black background and mis-placed text

VERIFIED FIXED in mozilla18

Status

()

VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: bjacob, Assigned: cjones)

Tracking

({regression})

unspecified
mozilla18
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [LOE:S])

Attachments

(1 attachment)

This is on a Otoro ICS and a b2g build from today.

STR: enter google.com in the URL bar.

Result: the page is rendered on a black background. The text elements are rendered at erratic locations which seem to change upon zooming/panning.

This might be related to bug 790723.
(Reporter)

Updated

6 years ago
Depends on: 790768
This looks pretty awful on screen - we need to fix this.
blocking-basecamp: --- → ?

Updated

6 years ago
Keywords: regression
There are a variety of issues on file for this, and it's not clear yet whether it's a gaia or gecko bug, but the underlying problem absolutely blocks.
This is a gecko bug.
blocking-basecamp: ? → +
Component: General → Graphics: Layers
OS: Linux → All
Product: Boot2Gecko → Core
Hardware: x86_64 → All
Created attachment 660625 [details] [diff] [review]
Make <html:iframe mozbrowser remote> behave like <xul:iframe remote>

I don't know why <html:browser remote> doesn't like being a non-root content document.  I suspect it has something to do with displayport, which has never been tested in that environment.

I have more important bugs to work on than deeply investigating non-shipping configurations of this code, so I offer up this hack-ish patch instead.
Assignee: nobody → jones.chris.g
Attachment #660625 - Flags: review?(roc)
Whiteboard: [LOE:S]

Updated

6 years ago
Keywords: verifyme
QA Contact: jsmith

Comment 6

6 years ago
https://hg.mozilla.org/mozilla-central/rev/304ab1446b9c
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18

Updated

6 years ago
Status: RESOLVED → VERIFIED
Keywords: verifyme
(Reporter)

Updated

6 years ago
Duplicate of this bug: 790723
You need to log in before you can comment on or make changes to this bug.