Closed Bug 790787 Opened 7 years ago Closed 6 years ago

Enable all relevant marionette unit tests for B2G

Categories

(Testing :: Marionette, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla26

People

(Reporter: mdas, Assigned: jgriffin)

Details

Attachments

(1 file, 1 obsolete file)

looking at mozilla-central/testing/marionette/client/marionette/tests/unit/unit-tests.ini, there are lot of tests that are marked b2g = false when they shouldn't be. We should be running these tests in the B2G environment. 

If you enable these tests, and once bug 775116 lands, then you'll see these errors when the chrome tests run:

E/GeckoConsole(   42): [JavaScript Error: "not well-formed" {file: "chrome://marionette/content/test_nested_iframe.xul" line: 10 column: 2 source: "</dialog>"}]

even though these tests pass in the Firefox environments.

If you disable the chrome tests (by using skip_if_b2g decorator) and only run the content tests, then you'll see 2 new test failures:

======================================================================
FAIL: test_execute_permission (test_execute_async_script.TestExecuteAsyncContent)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/b2g/Code/mozilla-b2g-emu/gecko/testing/marionette/client/marionette/tests/unit/test_execute_async_script.py", line 73, in test_execute_permission
    """)
AssertionError: JavascriptException not raised

======================================================================
FAIL: test_execute_permission (test_execute_script.TestExecuteContent)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/b2g/Code/mozilla-b2g-emu/gecko/testing/marionette/client/marionette/tests/unit/test_execute_script.py", line 28, in test_execute_permission
    """)
AssertionError: JavascriptException not raised

I'm not sure how this is related yet, so I'm raising this bug to enable these tests and track down the cause of these failures
Assignee: nobody → jgriffin
Attached patch Enable more unit tests on B2G, (obsolete) — Splinter Review
This patch breaks out chrome tests into separate files so that we can run content tests in B2G.
Attachment #786621 - Flags: review?(mdas)
Comment on attachment 786621 [details] [diff] [review]
Enable more unit tests on B2G,

Review of attachment 786621 [details] [diff] [review]:
-----------------------------------------------------------------

test_text_chrome.py isn't added to the unit-tests.ini file, can it be tested and added?
Attachment #786621 - Flags: review?(mdas) → review+
test_text_chrome.py is actually entirely commented out (as in the original) because it isn't working properly; I think I can add it to the manifest with "disabled = Bug xyz", which I'll do.
Added (but disabled) test_text_chrome.py
Attachment #786621 - Attachment is obsolete: true
Comment on attachment 786633 [details] [diff] [review]
Enable more unit tests on B2G,

Carry r+ forward.
Attachment #786633 - Flags: review+
try is green
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b0bc489229e0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.