Closed Bug 790795 Opened 8 years ago Closed 8 years ago

mozApps.installPackage doesn't call onsuccess/onerror handlers

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set
normal

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
mozilla18
blocking-basecamp +

People

(Reporter: dchanm+bugzilla, Unassigned)

Details

Attachments

(1 file)

The DOMRequest onsuccess/onerror handlers for installPackage are never called due to a typo.

STR
1. Visit
http://people.mozilla.com/~fdesre/openwebapps/test.html
2. Click install packaged app
3. Click install

Result
onsuccess/onerror is not called

Expected
handlers fire

Patch attached. Could someone land it?
blocking-basecamp: --- → ?
Keywords: regression
Attachment #660603 - Flags: review+
This wasn't a regression?
https://hg.mozilla.org/mozilla-central/rev/55a8de7b56b0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Wouldn't want this to regress.
blocking-basecamp: ? → +
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.