Closed Bug 790807 Opened 8 years ago Closed 8 years ago

Add nsA[C]String::ToInteger64

Categories

(Core :: XPCOM, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: sworkman, Assigned: sworkman)

References

Details

Attachments

(1 file)

DASH (Dynamic Adaptive Streaming over HTTP - bug 734546) requires string to 64-bit integer conversion for processing HTTP byte range responses for files of size >2GB.

Some background on DASH for Firefox:
We're implementing the WebM On Demand profile, which means non-muxed (separate audio and file streams), non-chunked (single files per stream) media. We download the media files in chunks corresponding to HTTP byte range requests. This is to allow for adaptive stream switching between chunks, i.e. switching between streams which are encoded at different bitrates in response to changes in network bandwidth.
Since video files can easily be >2GB, and DASH-WebM On Demand is based on byte range requests for single files, DASH in Gecko needs to be able to parse HTTP responses into 64 bit integers in order to address byte ranges >2GB.
Attachment #660612 - Flags: review?(benjamin)
First patch uploaded at bug creation:
-- Adds nsA[C]String::ToInteger64. Code from existing ToInteger implementation was simply copied and adjusted to deal with 64 bit integers. In order to avoid regressions of what is surely a heavily used function, no code is directly shared, just copied.

Let me know if avoiding regressions in this way is what you want to do, or if there's another approach you want to take.
Attachment #660612 - Flags: review?(benjamin) → review+
Thanks for the r+!
https://hg.mozilla.org/mozilla-central/rev/607ed3a68688
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.