firefox.com/m redirects to 404 on non-English browsers

VERIFIED WORKSFORME

Status

www.mozilla.org
Legacy PHP system
P4
normal
VERIFIED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Bartosz Piec, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [triaged 20120914])

(Reporter)

Description

5 years ago
On the Firefox stickers we got on MozCamp there was the following address: firefox.com/m

On en-US browser it redirects correctly to http://www.mozilla.org/en-US/firefox/fx/ but on pl (and maybe other locales) it redirects to http://www.mozilla.org/pl/m which does not exist.

I don't know what the correct redirection should be because on http://www.mozilla.org/pl/firefox/fx/ there isn't much about Firefox for Android. The best website I've found is probably http://www.mozilla.org/pl/mobile/

Updated

5 years ago
Whiteboard: [pending triage]

Comment 1

5 years ago
[jakemaul@jakebook ~]$ curl -v http://firefox.com/m
< Location: http://www.firefox.com/m

[jakemaul@jakebook ~]$ curl -v http://www.mozilla.org/m
< Location: http://www.mozilla.org/m

[jakemaul@jakebook ~]$ curl -v http://www.mozilla.org/m
< Location: http://www.mozilla.org/en-US/m


This may or may not be related to the fact that a number of redirects in the Apache config for Bedrock are hard-coded to en-US. Many of these were done before there was localized content for those pages in Bedrock.

Rik: do you have any good ideas on where we can start on this particular bug?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Whiteboard: [pending triage] → [triaged 20120914]

Comment 2

5 years ago
www.mozilla.org.conf:    RewriteRule ^/en-US/mobile(/?)$ /b/en-US/mobile$1 [PT]

So we rewrite to the Django app, but *only* for en-US... and that's for /mobile, not /m.

Looks like we have 2 issues here... /m doesn't go to the /mobile page, and the /mobile page only goes to the Django app in en-US.


I'm punting this to the "www.mozilla.org" product for advice.
Assignee: server-ops-webops → nobody
Component: Server Operations: Web Operations → Pages & Content
Product: mozilla.org → www.mozilla.org
QA Contact: cshields
The problem to solve here is http://www.mozilla.org/m should not redirect to http://www.mozilla.org/{locale}/m. This is certainly a mix of PHP and htaccess, yeah.

Guess I shall take this.

Also gonna had a test in mcom-tests when it's done.
Component: Pages & Content → Legacy PHP system
(Reporter)

Comment 4

5 years ago
Any progress on this? Is the address firefox.com/m still used somewhere?
AFAIK, firefox.com/m is not used anywhere.
curl -IL firefox.com/m
HTTP/1.1 301 Moved Permanently
Server: Apache
X-Backend-Server: pp-web04
Vary: Accept-Encoding
Content-Type: text/html; charset=iso-8859-1
Date: Mon, 08 Apr 2013 15:26:16 GMT
Location: http://www.firefox.com/m
Transfer-Encoding: chunked
Connection: Keep-Alive
X-Cache-Info: caching

HTTP/1.1 302 Found
Server: Apache
X-Backend-Server: pp-web04
Vary: Accept-Encoding
Content-Type: text/html; charset=iso-8859-1
Date: Mon, 08 Apr 2013 15:26:16 GMT
Location: http://www.mozilla.org/m
Transfer-Encoding: chunked
Connection: Keep-Alive
X-Cache-Info: not cacheable; response is 302 without expiry time

HTTP/1.1 301 Moved Permanently
Server: Apache
X-Backend-Server: bedrock2.webapp.phx1.mozilla.com
Vary: User-Agent,Accept-Language, Accept-Encoding
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0, private
Content-Type: text/html; charset=UTF-8
Date: Mon, 08 Apr 2013 15:26:16 GMT
Location: http://www.mozilla.org/en-US/m
Pragma: no-cache
Transfer-Encoding: chunked
Connection: Keep-Alive
X-Robots-Tag: noodp
X-Cache-Info: not cacheable; response specified "Cache-Control: no-store"

HTTP/1.1 301 Moved Permanently
Server: Apache
X-Backend-Server: bedrock2.webapp.phx1.mozilla.com
Vary: Accept-Encoding
Cache-Control: max-age=900
Content-Type: text/html; charset=iso-8859-1
Date: Mon, 08 Apr 2013 15:26:16 GMT
Location: http://www.mozilla.org/en-US/firefox/fx/
Expires: Mon, 08 Apr 2013 15:41:16 GMT
Transfer-Encoding: chunked
X-Robots-Tag: noodp
Connection: Keep-Alive
X-Cache-Info: caching

HTTP/1.1 200 OK
Server: Apache
X-Backend-Server: bedrock1.webapp.phx1.mozilla.com
Vary: Accept-Encoding
Cache-Control: max-age=600
Content-Type: text/html; charset=utf-8
Date: Mon, 08 Apr 2013 15:26:16 GMT
Expires: Mon, 08 Apr 2013 15:36:17 GMT
Transfer-Encoding: chunked
Connection: Keep-Alive
x-frame-options: DENY
X-Cache-Info: caching
This is still relevant.

Updated

5 years ago
Blocks: 879544
I cannot reproduce the issue now. 

If the locale is pl, I'm redirected from firefox.com/m to
https://www.mozilla.org/pl/firefox/new/?utm_source=firefox-com&utm_medium=referral
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

4 years ago
I don't know if the redirect address is correct but currently it redirects to Polish Fx site, not to 404.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.