Closed Bug 790950 Opened 12 years ago Closed 12 years ago

No video playback from OMX.TI.DUCATI1.VIDEO.DECODER on metacafe.com

Categories

(Core :: Audio/Video, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: aaronmt, Assigned: cpeterson)

References

()

Details

Currently when one plays any video on http://www.metacafe.com; one will hear audio but not receive any video playback.

I have tried forcing media.stagefright.omxcodec.flags to software and hardware decoding and this made no difference.

Only details in logcat I see:

I/OMXClient( 6308): Using client-side OMX mux.
I/OmxPlugin( 6308): media.stagefright.omxcodec.flags=16
I/OMXCodec( 6308): [OMX.TI.DUCATI1.VIDEO.DECODER] AVC profile = 100 (High), level = 30
I/OMXCodec( 6308): [OMX.TI.DUCATI1.VIDEO.DECODER] video dimensions are 640 x 360
I/OMXCodec( 6308): [OMX.TI.DUCATI1.VIDEO.DECODER] Crop rect is 640 x 360 @ (0, 0)
I/OmxPlugin( 6308): stride not available, assuming width
I/OmxPlugin( 6308): slice height not available, assuming height
I/OmxPlugin( 6308): rotation not available, assuming 0
I/OmxPlugin( 6308): width: 640 height: 360 component: OMX.TI.DUCATI1.VIDEO.DECODER format: 0x7f000100 stride: 640 sliceHeight: 360 rotation: 0
I/SoftAAC2( 6308): Reconfiguring decoder: 44100 Hz, 2 channels

--
Galaxy Nexus (Android 4.1.1)
Nightly (09/13)
OS: Mac OS X → Android
Hardware: x86 → ARM
Aaron, I think this is a dupe of bug 784329. Does the video play if you change about:config pref "media.stagefright.omxcodec.flags" from 0 ("use hardware decoder, if available") to 8 ("force software decoder")?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
As mentioned, in comment #0 there is no difference amongst the flag values.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
http://mozbugs.github.cscott.net/videobug/ (from bug 791500) is another test case.
This may be two separate issues.

When I force hardware decoding, I see a logcat error about "Unknown video color format: 0x7f000100". This will soon be fixed by bug 784329.

I/OmxPlugin(13377): media.stagefright.omxcodec.flags=16
I/OmxPlugin(13377): FORCE HARDWARE DECODING
I/OMXCodec(13377): [OMX.TI.DUCATI1.VIDEO.DECODER] AVC profile = 100 (High), level = 30
...
I/OmxPlugin(13377): width: 768 height: 464 component: OMX.TI.DUCATI1.VIDEO.DECODER format: 0x7f000100 stride: 768 sliceHeight: 464 rotation: 0
I/OmxPlugin(13377): Unknown video color format: 0x7f000100


When I force software decoding, Stagefright's software decoder fails with H264SWDEC_STRM_ERR ("Decoder failed: -2"). ERROR(0x80001001) means OMX_ErrorUndefined. I haven't figured out yet what the -1007 error code means.

I/OmxPlugin(13377): media.stagefright.omxcodec.flags=8
I/OmxPlugin(13377): FORCE SOFTWARE DECODING
I/OMXCodec(13377): [OMX.google.h264.decoder] AVC profile = 100 (High), level = 30
I/OMXCodec(13377): [OMX.google.h264.decoder] video dimensions are 320 x 240
I/OMXCodec(13377): [OMX.google.h264.decoder] Crop rect is 320 x 240 @ (0, 0)
I/OmxPlugin(13377): stride not available, assuming width
I/OmxPlugin(13377): slice height not available, assuming height
I/OmxPlugin(13377): rotation not available, assuming 0
I/OmxPlugin(13377): width: 320 height: 240 component: OMX.google.h264.decoder format: 0x13 stride: 320 sliceHeight: 240 rotation: 0
I/SoftAAC2(13377): Reconfiguring decoder: 44100 Hz, 2 channels
I/OmxPlugin(13377): channelCount: 2 sampleRate: 44100
E/SoftAVC (13377): Decoder failed: -2
E/OMXCodec(13377): [OMX.google.h264.decoder] ERROR(0x80001001, -1007)
Assignee: nobody → cpeterson
Status: NEW → ASSIGNED
It seems that the video is H.264 high profile. IIRC, android's default h.264 software codec do not support high profile.
Thanks, Sotaro! It looks like Android's H.264 software decoder only supports Baseline Profile (and Level <= 5.1):

https://github.com/android/platform_frameworks_base/blob/fbb170ca9cbbd0c87c71ac39ecbb36086bca5ee2/media/libstagefright/codecs/on2/h264dec/SoftAVC.cpp#L31

So metacafe.com's hardware decoder problems are a dupe of (soone to be fixed) bug 784329 and its software decoder problems are a limitation of the platform.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → INVALID
Well that's disappointing to say the least. Playback (both audio and video) work perfectly fine in the Android AOSP Browser, Google Chrome, Dolphin and on iOS with Safari on both the iPad and iPhone.
The video on bug 791500 (marked a dup) is h.264 baseline.  But maybe that's an instance of bug 784329 ?
(Sorry for the spam, just noticed that Chris Peterson commented on bug 791500 confirming that it was a dupe of 784329.  So ignore comment 9.)
(In reply to Aaron Train [:aaronmt] from comment #8)
> Well that's disappointing to say the least. Playback (both audio and video)
> work perfectly fine in the Android AOSP Browser, Google Chrome, Dolphin and
> on iOS with Safari on both the iPad and iPhone.

Aaron, the metacafe.com videos will play correctly on the Galaxy Nexus (and use its hardware decoder) after I fix bug 784329.
(In reply to Chris Peterson (:cpeterson) from comment #11)
> (In reply to Aaron Train [:aaronmt] from comment #8)
> > Well that's disappointing to say the least. Playback (both audio and video)
> > work perfectly fine in the Android AOSP Browser, Google Chrome, Dolphin and
> > on iOS with Safari on both the iPad and iPhone.
> 
> Aaron, the metacafe.com videos will play correctly on the Galaxy Nexus (and
> use its hardware decoder) after I fix bug 784329.

Ah, I misread or misinterpreted the reason for invalid
You need to log in before you can comment on or make changes to this bug.