progress dialog performance

VERIFIED INVALID

Status

Core Graveyard
Installer: XPInstall Engine
P3
normal
VERIFIED INVALID
19 years ago
2 years ago

People

(Reporter: Cathleen, Assigned: dougt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Installing 1000 files on a P5-233 machine took roughly about 1 1/2 ~ 2 minutes,
but the progress dialog itself took about 4 minutes to finish.

Basically, the installation of the files are already done, but it took a lot
longer for the event loop to finish process all the events.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Assignee)

Comment 1

19 years ago
I do not believe that the problem is with the dialog/proxy code, rather the
delay you are seeing is the time it take for finalize to complete.  Please
verify this by setting a break point at the end of finalize install.  You will
see that your breakpoint will be hit then (a few hundred lines later) the dialog
will close.

I would agree that the dialog does not give you an indication of progress
during this stage, but I stand that the progress dialog performance is not a
the real problem.  If you care, please open up another bug which can address
this dialogs shortcomings.

I am going to mark as INVALID.
(Reporter)

Updated

19 years ago
Target Milestone: M11
(Reporter)

Comment 2

19 years ago
setting target milestone to M11

Need to get a copy of quantify to measure performance with and without UI
dialogs, in order to define the problem.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
So be it.

Comment 4

18 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.