Session restore won't fail if there are no tabs in JSON

VERIFIED FIXED in Firefox 16

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
9 months ago

People

(Reporter: bnicholson, Assigned: bnicholson)

Tracking

unspecified
Firefox 18
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox15 affected, firefox16 verified, firefox17 fixed, firefox18 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 660916 [details] [diff] [review]
Make sure tab exists for session restore

I ran into this while trying the STR in bug 789867:
1) Open Fennec
2) Go to any page
3) Push home and OOM Fennec
4) Reopen Fennec
5) While Fennec is loading, repeatedly hit the stop button to prevent the page from loading
6) Once the throbber has stopped and at a blank screen, push home and OOM Fennec again
7) Reopen Fennec

This results in the following sessionstore state:
{"windows":[{"tabs":[],"selected":1,"closedTabs":[]}]}

which happens because we clear the session data at startup, and we stopped the restored tab from loading, so no tabs get added. After step 7 above, the throbber spins endlessly and nothing loads in the browser. We should make sure there's at least one tab being restored.
Attachment #660916 - Flags: review?(mark.finkle)
(Assignee)

Updated

5 years ago
status-firefox15: --- → affected
status-firefox16: --- → affected
status-firefox17: --- → affected
status-firefox18: --- → affected
Attachment #660916 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 1

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/9a7b25bc580e
(Assignee)

Comment 2

5 years ago
Comment on attachment 660916 [details] [diff] [review]
Make sure tab exists for session restore

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Startup could hang (the throbber loops forever and the user can't load any pages)
Testing completed (on m-c, etc.): just landed
Risk to taking this patch (and alternatives if risky): very low
Attachment #660916 - Flags: approval-mozilla-release?
Attachment #660916 - Flags: approval-mozilla-beta?
Attachment #660916 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/9a7b25bc580e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18

Updated

5 years ago
status-firefox18: affected → ---
Setting status-firefox18 to fixed - Scoobidiver we are going to rely on status flags more than Target Milestones in the future so the best practice is not to clear a flag, but to set to fixed.
status-firefox18: --- → fixed
Attachment #660916 - Flags: approval-mozilla-beta?
Attachment #660916 - Flags: approval-mozilla-beta+
Attachment #660916 - Flags: approval-mozilla-aurora?
Attachment #660916 - Flags: approval-mozilla-aurora+
Comment on attachment 660916 [details] [diff] [review]
Make sure tab exists for session restore

We're not re-building 15 for this so minus on mozilla-release approval request.
Attachment #660916 - Flags: approval-mozilla-release? → approval-mozilla-release-
(Assignee)

Comment 6

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/7328213574c2
status-firefox17: affected → fixed
(Assignee)

Comment 7

5 years ago
http://hg.mozilla.org/releases/mozilla-beta/rev/0d33f954ee14
status-firefox16: affected → fixed

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox16: fixed → verified
status-firefox18: fixed → verified
You need to log in before you can comment on or make changes to this bug.