Addition to the public suffix list (betainabox.com)

RESOLVED FIXED in mozilla19

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: adrian, Assigned: gerv)

Tracking

Trunk
mozilla19
x86
macOS
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/536.25 (KHTML, like Gecko) Version/6.0 Safari/536.25

Steps to reproduce:

BetaInABox is a tool for quickly generating prototypes for web
software.  Each of our member get a subdomain, which can be used to
load their app -- e.g.:

www.betainabox.com -> my web site
app1.betainabox.com -> application 1
app2.betainabox.com -> application 2



Actual results:

user can attempt to set cookies to betainabox.com, which would then be contaminating other user's sites.


Expected results:

We would like to have betainabox.com added to the public suffix list
to make sure cookies would be protected between our member subdomains.
Posted patch Patch v.1 (obsolete) — Splinter Review
Assignee: nobody → gerv
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #672278 - Flags: review?(weppos)
Comment on attachment 672278 [details] [diff] [review]
Patch v.1

Review of attachment 672278 [details] [diff] [review]:
-----------------------------------------------------------------

I prepared an updated patch because of bug 791117 and to use consistent comment style. Hope you don't mind.
Attachment #672278 - Flags: review?(weppos) → review-
Posted patch PSL updatesSplinter Review
Attachment #672278 - Attachment is obsolete: true
Attachment #675026 - Flags: review?(gerv)
Attachment #675026 - Flags: review?(gerv) → review+
https://hg.mozilla.org/mozilla-central/rev/0ab2ca659ccf
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.