getBuildConfiguration() returns the wrong value for gczeal and threadsafe

VERIFIED FIXED in Firefox 17

Status

()

Core
JavaScript Engine
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: gkw, Assigned: gkw)

Tracking

({regression, verifyme})

Trunk
mozilla18
regression, verifyme
Points:
---

Firefox Tracking Flags

(firefox15 unaffected, firefox16 unaffected, firefox17 fixed, firefox18 verified, firefox-esr10 unaffected)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 661077 [details] [diff] [review]
patch

getBuildConfiguration returns the wrong value for threadsafe / gczeal, because they are both named has-gczeal. Thus,

getBuildConfiguration()["has-gczeal"]

returns false even though it is true in a build with gczeal enabled but threadsafety disabled.

The attached patch fixes it to "threadsafe", and removes a duplicated JSGC_ROOT_ANALYSIS ifdef block. The patch was r=sfink over irc.
Attachment #661077 - Flags: review+
(Assignee)

Updated

5 years ago
Summary: getBuildConfiguration returns the wrong value for threadsafe → getBuildConfiguration() returns the wrong value for gczeal and threadsafe
(Assignee)

Comment 1

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/e3799f9cfee8
Status: NEW → ASSIGNED
status-firefox-esr10: --- → unaffected
status-firefox15: --- → unaffected
status-firefox16: --- → unaffected
status-firefox17: --- → affected
status-firefox18: --- → fixed
Target Milestone: --- → mozilla18
https://hg.mozilla.org/mozilla-central/rev/e3799f9cfee8
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

5 years ago
In m-c changeset 9fff2012b66c 64-bit debug shell,

js> getBuildConfiguration()
({debug:true, dtrace:false, e4x:true, 'exact-rooting':false, 'generational-gc':false, 'has-ctypes':false, 'has-gczeal':true, 'incremental-gc':true, methodjit:true, 'more-deterministic':true, 'oom-backtraces':false, profiling:false, 'rooting-analysis':false, threadsafe:false, 'trace-jscalls-api':false, valgrind:true})
js> getBuildConfiguration()['threadsafe']
false
js> getBuildConfiguration()['rooting-analysis']
false
js> getBuildConfiguration()['has-gczeal']       
true
js>

gives the correct values. Thus, verified.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 4

5 years ago
Comment on attachment 661077 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 776632 and bug 776732
User impact if declined: wrong output in Firefox 17 js shell
Testing completed (on m-c, etc.): verified fixed
Risk to taking this patch (and alternatives if risky): no risk, shell only
String or UUID changes made by this patch: none
Attachment #661077 - Flags: approval-mozilla-aurora?
Attachment #661077 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/866e54dbaead
status-firefox17: affected → fixed
status-firefox18: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.