[b2g-bluetooth] Send system message when pairing process is finished

RESOLVED FIXED in mozilla18

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: gyeh, Assigned: gyeh)

Tracking

Trunk
mozilla18
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Whiteboard: [LOE:S] )

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
When we try to pair with other bluetooth device, a DOMRequest will be returned first to make sure the pairing request is successfully transferred to dbus and start the pairing process. (This will be modified in another bug.)

And after the pairing process is finished, Gaia will be notified by a system message.
(Assignee)

Updated

6 years ago
Blocks: 791147
(Assignee)

Comment 1

6 years ago
Created attachment 661568 [details] [diff] [review]
v1: Send system message when pairing process is finished
Attachment #661568 - Flags: review?(kyle)
(Assignee)

Comment 2

6 years ago
Created attachment 661693 [details] [diff] [review]
Final version: Send system message when pairing process is finished, r=qdot

try server:

https://tbpl.mozilla.org/?tree=Try&rev=53f136f0877a
https://tbpl.mozilla.org/?tree=Try&rev=d63af3cba1c7
Attachment #661568 - Attachment is obsolete: true
(Assignee)

Updated

6 years ago
Whiteboard: [LOE:S]
https://hg.mozilla.org/mozilla-central/rev/34c9452fd3bf
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18

Updated

6 years ago
Blocks: 795458
(Assignee)

Updated

6 years ago
Duplicate of this bug: 783959
You need to log in before you can comment on or make changes to this bug.